Reply
Highlighted
New Contributor
Posts: 4
Registered: ‎04-26-2016
Accepted Solution

Build failed for spark thriftserver - CDH5.10.0

[ Edited ]

I'm trying to compile spark 1.6.0-cdh 5.10.0 on a Docker container (that should act as an edge node for the cluster with Jupiter).

This is the source:

http://archive.cloudera.com/cdh5/cdh/5/spark-1.6.0-cdh5.10.0-src.tar.gz

I am using the following Maven command:

build/mvn -Pyarn -Phadoop-2.6 -Dhadoop.version=$V_CDH -Phive -Phive-thriftserver -DskipTests clean package

but I cannot continue over the thriftserver part.

I always get this error:

 

[error] /usr/local/spark-1.6.0-cdh5.10.0/sql/hive-thriftserver/src/main/scala/org/apache/spark/sql/hive/thriftserver/SparkExecuteStatementOperation.scala:42: class SparkExecuteStatementOperation needs to be abstract, since method cancel in class Operation of type (x$1: org.apache.hive.service.cli.OperationState)Unit is not defined
[error] private[hive] class SparkExecuteStatementOperation(
[error]                     ^
[error] /usr/local/spark-1.6.0-cdh5.10.0/sql/hive-thriftserver/src/main/scala/org/apache/spark/sql/hive/thriftserver/SparkExecuteStatementOperation.scala:252: method cancel overrides nothing.
[error] Note: the super classes of class SparkExecuteStatementOperation contain the following, non final members named cancel:
[error] def cancel(x$1: org.apache.hive.service.cli.OperationState): Unit
[error]   override def cancel(): Unit = {
[error]                ^
[error] /usr/local/spark-1.6.0-cdh5.10.0/sql/hive-thriftserver/src/main/scala/org/apache/spark/sql/hive/thriftserver/server/SparkSQLOperationManager.scala:42: method newExecuteStatementOperation overrides nothing.
[error] Note: the super classes of class SparkSQLOperationManager contain the following, non final members named newExecuteStatementOperation:
[error] def newExecuteStatementOperation(x$1: org.apache.hive.service.cli.session.HiveSession,x$2: String,x$3: java.util.Map[String,String],x$4: Boolean,x$5: Long): org.apache.hive.service.cli.operation.ExecuteStatementOperation
[error]   override def newExecuteStatementOperation(

Any idea?

Thanks in advance,

Lorenzo

Cloudera Employee
Posts: 461
Registered: ‎08-11-2014

Re: Build failed for spark thriftserver - CDH5.10.0

Yes, the thrift server isn't shipped or supported, in part because it doesn't work with the later Hive shipped by CDH. I don't think it will build with this profile enabled.

New Contributor
Posts: 4
Registered: ‎04-26-2016

Re: Build failed for spark thriftserver - CDH5.10.0

Ok,
Thanks,
Lorenzo
Announcements