Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎10-13-2017

Spark 2.2 - Port conflict detected: 18089 (History Server WebUI Port) is also used by: History Serv

Hi

 

deployed spark 2.2 on CDH 5.12. After the deployment and service restart got below error.

 

spark 2 Port conflict detected: 18089 (History Server WebUI Port) is also used by: History Server (quickstart).

 

Similiar error was also reported for TLS port.

 

After this i found that Spark 2 was also installed automatically as part of the spark 2.2 deployment which i think was creating this port conflict. IS it normal behaviour to install both Spark 2 and 2.2 automatically.

 

Also I had stopped the service of spark 2 and retsarted 2.2 but still the same error continued untill the point i changed the value of port in spark 2. Should'nt the stopping of the service for spark 2 sufficent to avoid the error

 

Regards

Vinay Jain

Announcements