Reply
Highlighted
tuk
Explorer
Posts: 14
Registered: ‎12-05-2017

Is hadoop-yarn-api backward compatiable?

Is `hadoop-yarn-api` backward compatible? I can find this blog post which talks about `hbase-client` api. Does the same thiing old for `hadoop-yarn-api` as well for `2.6.0-cdh5.13.0` and `2.6.0-cdh5.7.0` ?

 

 

<dependency>
<groupId>org.apache.hadoop</groupId>
<artifactId>hadoop-yarn-api</artifactId>
<version>2.6.0-cdh5.13.0</version>
</dependency> 

 

 

Posts: 1,760
Kudos: 379
Solutions: 282
Registered: ‎07-31-2013

Re: Is hadoop-yarn-api backward compatiable?

Yes, it should remain compatible within a CDH major release (such as CDH 5.*). That is, CDH 5.7.0 API backed client runtimes will continue to work with CDH 5.13.0 services.
Announcements