Reply
Posts: 1,749
Kudos: 365
Solutions: 277
Registered: ‎07-31-2013

Re: Oozie/hive-server2 not able to connect to hive-metastore when SASL enabled

[ Edited ]

Sorry, the XML appears to have got eaten up. Here's clearer instructions for releases prior to CDH 5.1.0:

 

# SSH to Oozie machine
# Log on as root
# Do below:
cat > /tmp/hive-site.xml
<configuration><property><name>hadoop.rpc.protection</name><value>privacy</value></property></configuration>
^D
cd /tmp/
jar cf hive-rpc-protection.jar hive-site.xml
mv hive-rpc-protection.jar /var/lib/oozie/
# Restart Oozie server, and retry your WF.

New Contributor
Posts: 7
Registered: ‎04-21-2014

Re: Oozie/hive-server2 not able to connect to hive-metastore when SASL enabled

Thanks Harsh, that worked.
Highlighted
New Contributor
Posts: 2
Registered: ‎06-10-2017

Re: Oozie/hive-server2 not able to connect to hive-metastore when SASL enabled

[ Edited ]

Hi,

 

Are there any instructions for CDH 5.13.1 ?

 

I have a similar error message for the same config. 

 

Hadoop RPC Protection: Authenticate

 

Error Message:

WARN org.apache.oozie.action.hadoop.HCatCredentials: SERVER[myhost] USER[ABC] Group[ABC] APP[ABCDEFGHIJKL] JOB[JOBID] Action[MyAction] Exception in addtoJobConf
org.apache.hive.hcatalog.common.HCatException : 9001 : Exception occurred while processing HCat request : TException while getting delegation token.. Cause : org.apache.thrift.transport.TTransportException: java.net.SocketException: Connection reset

 

Announcements