Reply
Highlighted
New Contributor
Posts: 4
Registered: ‎10-16-2017
Accepted Solution

oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Failed

Hello All

I'm getting the following error with any oozie client commands

Authentication exception: GSSException: No valid credentials provided (Mechanism level: Failed to find any Kerberos credentails)

 It was working well untilk a few days ago when this started.

I have a valid kerberos ticket (klist + hdfs dfs -ls / or anything but oozie work perfectly well).

Also restarted oozie, no better luck

Any ideas, I could not find anything wrong with the configuration so far

Thank you for any suggestion!

Ioan

Cloudera Employee
Posts: 375
Registered: ‎03-23-2015

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

Can you please share the Oozie command that you ran? Also, any errors you can capture from the Oozie server log?

Have you also tried a few different users, like "hdfs", "oozie", "hive" etc to see if behaviours are different due to user difference?
New Contributor
Posts: 4
Registered: ‎10-16-2017

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

Hello

 

Any oozie client command fails, the specific one I used is

oozie jobs -auth KERBEROS  -oozie https://[redacted-server-same]:11443/oozie

 

Any other Hadoop works perfectly (with same keytab) - for example hdfs dfs -ls / works like a charm

Thanks for your help

Ioan

New Contributor
Posts: 4
Registered: ‎10-16-2017

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

I was able to resolve the issue by doing the following:

- remove LB name from oozie in CM + restart oozie

- put back the LB name in oozie + restart oozie

Then it worked, it probably needed to regenerate some krb tickets

Ioan

Cloudera Employee
Posts: 375
Registered: ‎03-23-2015

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

Good finding, looks like the keytab file for Oozie was outdated.
New Contributor
Posts: 2
Registered: ‎04-25-2018

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

Hi 

 

When you say LB name, what is it that you are referring to in the CM config.

 

Thanks,

Vinay Nallan.

Cloudera Employee
Posts: 375
Registered: ‎03-23-2015

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

@Vinay,

I would think it is "Oozie Load Balancer" under CM > Oozie > Configuration.
New Contributor
Posts: 4
Registered: ‎10-16-2017

Re: oozie Authentication exception: GSSException: No valid credentials provided (Mechanism level: Fa

Hi folks -

From talking to support, it seems the issue could be related to HA Proxy.

As a "resolkution", we have disabled HA and everything works great.

Let's face it - we do not really need HA for oozie client - so this was an acceptable enough resolution for us

Thank you for following up though!

Ioan

Announcements