Reply
New Contributor
Posts: 3
Registered: ‎11-22-2016
Accepted Solution

impala-kudu not working in impala-kudu ?

Hi all,

I follow the CDH official documents and finish the installation of impala-kudu, but I can not let it working in impala-shell. Please see the following comands:

[root@slave03 ~]# aleternatives --display impala-shell
-bash: aleternatives: command not found
[root@slave03 ~]# alternatives --display impala-shell
impala-shell - status is manual.
link currently points to /opt/cloudera/parcels/IMPALA_KUDU-2.7.0-2.cdh5.9.0.p0.109/bin/impala-shell
/opt/cloudera/parcels/CDH-5.5.1-1.cdh5.5.1.p0.11/bin/impala-shell - priority 10
/opt/cloudera/parcels/IMPALA_KUDU-2.7.0-2.cdh5.9.0.p0.109/bin/impala-shell - priority 5
Current `best' version is /opt/cloudera/parcels/CDH-5.5.1-1.cdh5.5.1.p0.11/bin/impala-shell.
[root@slave03 ~]# impala-shell
Starting Impala Shell without Kerberos authentication
Connected to slave03:21000
Server version: impalad version 2.8.0-cdh5-INTERNAL RELEASE (build )
***********************************************************************************
Welcome to the Impala shell.
(Impala Shell v2.8.0-cdh5-INTERNAL () built on Fri Sep 16 00:09:21 PDT 2016)
When pretty-printing is disabled, you can use the '--output_delimiter' flag to set
the delimiter for fields in the same row. The default is ','.
***********************************************************************************
[slave03:21000] > select version() as s;
Query: select version() as s
Query submitted at: 2016-11-22 23:45:56 (Coordinator: http://slave03:25000)
Query progress can be monitored at: http://slave03:25000/query_plan?query_id=34c6e1e086fd936:4db9687300000000
+------------------------------------------------------+
| s |
+------------------------------------------------------+
| impalad version 2.8.0-cdh5-INTERNAL RELEASE (build ) |
| Built on Fri, 16 Sep 2016 00:20:33 PST |
+------------------------------------------------------+
Fetched 1 row(s) in 0.02s
[slave03:21000] >

1. I already install the kudu and add kudu service successfully.
2. Active impala-kudu parcel successfully.
3. Set the IMPALA_KUDU=1 for new added impala service.
4. Restart impala service.
5. Excec the command "alternatives --set impala-shell ........"

Any one can help me ?

Thanks a lot.

Cloudera Employee
Posts: 18
Registered: ‎02-05-2016

Re: impala-kudu not working in impala-kudu ?

You did the right thing and you are running the correct impala-shell.

We made a mistake when building IMPALA_KUDU 2.7.0-2: we forgot to change the behavior of "select version() as s" in impala-shell to return a string containing "KUDU".

So, just ignore the result of "select version() as s" and try to use Impala with a Kudu table. It should work.
New Contributor
Posts: 3
Registered: ‎11-22-2016

Re: impala-kudu not working in impala-kudu ?

Thanks a lot. I will try. 

Announcements