Answer
New Contributor
Posts: 3
Registered: ‎06-06-2018
Installation fails ,Could not initialize database server.

 vi 6.start-cloudera-scm-server-db.log
 
Could not initialize database server.
  This usually means that your PostgreSQL installation failed or isn't working properly.
  PostgreSQL is installed using the set of repositories found on this machine. Please
  ensure that PostgreSQL can be installed. Please also uninstall any other instances of
  PostgreSQL and then try again., giving up

2 people had this problem.
Other Answers: 2
Cloudera Employee
Posts: 13
Registered: ‎04-21-2016
Answered

Please identify the OS being used.

Was postgres correctly installed?

Is postgres running?

Please post all of the log files from the installer directory.

New Member
Posts: 1
Registered: ‎06-29-2018
Answered
[ Edited ]

I ran into the same issue but was able to resolve it. I am installing on CentOS7 with the following:

 

Virtual Machine on ESXi 6.7, 100GB disk, 4GB RAM, CentOS-7-x86_64-DVD-1804.iso

 

1. Selected minimal package install.

2. Disabled security policy.

3. Install

4. Reboot

 

Logged in as root.

1. Edit /etc/sysconfig/selinux and change to Permissive.

2. yum install wget ntp ntpdate psmisc

3. Set the date using ntpdate command (optional)

4. systemctl disable firewalld

4. Reboot

 

Logged in as root and installed the software.

 

History was as follows:

 

3 getenforce
4 vi /etc/sysconfig/selinux
5 yum install -y psmisc
6 pstree
8 yum install ntp ntpdate
9 grep pool /etc/ntp.conf
13 ntpdate 0.centos.pool.ntp.org
14 sync
15 reboot
16 getenforce
17 wget https://archive.cloudera.com/cm6/6.0.0-beta1/cloudera-manager-installer.bin
18 ls -ltr
19 chmod +x cloudera-manager-installer.bin
20 ./cloudera-manager-installer.bin

 

Install completed successfully and I am now proceeding with the rest of the install via browser.

 

For me I noticed my base install was missing pstree (I saw that error in the log) and there was also a bunch of permissioned denied messages. On the third try I add psmisc and coincidentally disabled the security policy at the start. I believe one of those two may have fixed it. Not sure.

 

Hope this helps.

-bill