Reply
Highlighted
How
New Contributor
Posts: 1
Registered: ‎02-01-2019

Install OpenJDK 1.8 for CDH 5.16.1

I tried upgrade to OpenJDK 1.8 for CDH 5.16.1, but I met couple of problem during installation.

 

I ran the command: yum install java-1.8.0-openjdk-devel.

But, It needs me to downgrade my glibc from 2.17-196 into 2.17-157, I did, then I got more errors:

 

Protected multilib versions: libuuid-2.23.2-33.el7_3.2.i686 != libuuid-2.23.2-43.el7.x86_64
Error: Protected multilib versions: libstdc++-4.8.5-11.el7.i686 != libstdc++-4.8.5-16.el7.x86_64
Error: Protected multilib versions: libgcc-4.8.5-11.el7.i686 != libgcc-4.8.5-16.el7.x86_64
Error: Protected multilib versions: libXrender-0.9.8-2.1.el7.i686 != libXrender-0.9.10-1.el7.x86_64
Error: Protected multilib versions: libxcb-1.11-4.el7.i686 != libxcb-1.12-1.el7.x86_64
Error: Protected multilib versions: nss-3.28.4-1.2.el7_3.i686 != nss-3.28.4-8.el7.x86_64
Error: Protected multilib versions: 1:java-1.8.0-openjdk-headless-1.8.0.131-3.b12.el7_3.i686 != 1:java-1.8.0-openjdk-headless-1.8.0.131-11.b12.el7.x86_64
Error: Protected multilib versions: alsa-lib-1.1.1-1.el7.i686 != alsa-lib-1.1.3-3.el7.x86_64
Error: Protected multilib versions: fontconfig-2.10.95-10.el7.i686 != fontconfig-2.10.95-11.el7.x86_64
Error: Protected multilib versions: libXtst-1.2.2-2.1.el7.i686 != libXtst-1.2.3-1.el7.x86_64
Error: Protected multilib versions: nss-softokn-freebl-3.16.2.3-14.4.el7.i686 != nss-softokn-freebl-3.28.3-6.el7.x86_64
Error: Protected multilib versions: freetype-2.4.11-12.el7.i686 != freetype-2.4.11-15.el7.x86_64
Error: Protected multilib versions: libX11-1.6.3-3.el7.i686 != libX11-1.6.5-1.el7.x86_64
Error: Protected multilib versions: libXi-1.7.4-2.el7.i686 != libXi-1.7.9-1.el7.x86_64
Error: Protected multilib versions: readline-6.2-9.el7.i686 != readline-6.2-10.el7.x86_64

 

Is there any one who can tell me how to solve these problems?

Announcements