Reply
Expert Contributor
Posts: 205
Registered: ‎07-01-2015

Python3 compatibility issues - warnings

[ Edited ]

Hi Cloudera,

 in jupyter notebooks I got a warning about invalida escape sequences.

I think this is related to the fact,that I am using Python3 instead of Python2.

 

Can I edit those python files, or is there any workaround for this?

Thanks

 

/opt/cloudera/parcels/SPARK2-2.2.0.cloudera1-1.cdh5.12.0.p0.142354/lib/spark2/python/lib/py4j-0.10.4-src.zip/py4j/java_gateway.py:1890: DeprecationWarning: invalid escape sequence \*
/opt/cloudera/parcels/SPARK2-2.2.0.cloudera1-1.cdh5.12.0.p0.142354/lib/spark2/python/lib/py4j-0.10.4-src.zip/py4j/java_gateway.py:1890: DeprecationWarning: invalid escape sequence \*
/opt/cloudera/parcels/SPARK2-2.2.0.cloudera1-1.cdh5.12.0.p0.142354/lib/spark2/python/pyspark/sql/readwriter.py:398: DeprecationWarning: invalid escape sequence \`
  """
/opt/cloudera/parcels/SPARK2-2.2.0.cloudera1-1.cdh5.12.0.p0.142354/lib/spark2/python/pyspark/sql/readwriter.py:759: DeprecationWarning: invalid escape sequence \`
  """
/opt/cloudera/parcels/SPARK2-2.2.0.cloudera1-1.cdh5.12.0.p0.142354/lib/spark2/python/pyspark/sql/streaming.py:618: DeprecationWarning: invalid escape sequence \`
  """
/opt/cloudera/parcels/SPARK2-2.2.0.cloudera1-1.cdh5.12.0.p0.142354/lib/spark2/python/pyspark/sql/functions.py:1519: DeprecationWarning: invalid escape sequence \d
  """

 

Announcements