Reply
jkt
Explorer
Posts: 7
Registered: ‎05-17-2018

CDSW-Application deamon down after installation

Hi,

I'm new in CDSW. After install, the application deamon down.

Here is what I have when I type command: cdsw status

[root@cdsw-node1 ~]# cdsw status
Sending detailed logs to [/tmp/cdsw_status_yMhJ9y.log] ...
CDSW Version: [1.3.0:9bb84f6]
OK: Application running as root check
OK: Sysctl params check
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
|             NAME            |   STATUS   |           CREATED-AT          |   VERSION   |   EXTERNAL-IP   |          OS-IMAGE         |         KERNEL-VERSION         |   GPU   |   STATEFUL   |
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
|   cdsw-node1.softovh.corp   |    True    |   2018-05-19 14:14:37+00:00   |   v1.6.11   |       None      |   CentOS Linux 7 (Core)   |   3.10.0-693.21.1.el7.x86_64   |    0    |    False     |
|   cdsw-node2.softovh.corp   |    True    |   2018-05-19 14:14:55+00:00   |   v1.6.11   |       None      |   CentOS Linux 7 (Core)   |   3.10.0-693.21.1.el7.x86_64   |    0    |    False     |
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
2/2 nodes are ready.
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
|                         NAME                        |   READY   |    STATUS   |   RESTARTS   |           CREATED-AT          |        POD-IP       |       HOST-IP       |   ROLE   |
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
|             etcd-cdsw-node1.softovh.corp            |    1/1    |   Running   |      0       |   2018-05-19 14:15:38+00:00   |   192.168.113.226   |   192.168.113.226   |   None   |
|        kube-apiserver-cdsw-node1.softovh.corp       |    1/1    |   Running   |      0       |   2018-05-19 14:16:01+00:00   |   192.168.113.226   |   192.168.113.226   |   None   |
|   kube-controller-manager-cdsw-node1.softovh.corp   |    1/1    |   Running   |      0       |   2018-05-19 14:15:57+00:00   |   192.168.113.226   |   192.168.113.226   |   None   |
|              kube-dns-3911048160-x25d4              |    0/3    |   Pending   |      0       |   2018-05-19 14:14:53+00:00   |         None        |   192.168.113.226   |   None   |
|                   kube-proxy-86c0f                  |    1/1    |   Running   |      0       |   2018-05-19 14:14:53+00:00   |   192.168.113.226   |   192.168.113.226   |   None   |
|                   kube-proxy-b64tb                  |    1/1    |   Running   |      0       |   2018-05-19 14:14:55+00:00   |   192.168.113.227   |   192.168.113.227   |   None   |
|        kube-scheduler-cdsw-node1.softovh.corp       |    1/1    |   Running   |      0       |   2018-05-19 14:15:43+00:00   |   192.168.113.226   |   192.168.113.226   |   None   |
|                   weave-net-9w03g                   |    1/2    |   Running   |      6       |   2018-05-19 14:14:53+00:00   |   192.168.113.226   |   192.168.113.226   |   None   |
|                   weave-net-xw39b                   |    1/2    |   Running   |      6       |   2018-05-19 14:14:55+00:00   |   192.168.113.227   |   192.168.113.227   |   None   |
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Pods not ready in cluster kube-system ['k8s-app/kube-dns'].

Pods not ready in cluster default ['role/cron', 'role/db', 'role/engine-deps', 'role/ingress-controller', 'role/livelog', 'role/reconciler', 'role/spark-port-forwarder', 'role/web'].
Application services are incomplete. [web, db, livelog] not found.
Config maps are incomplete. [internal-config, installer-config] not found.
Secrets are incomplete. [docker-creds, internal-secrets, external-secrets] not found.
Persistent volumes are incomplete.
Persistent volume claims are incomplete.
Ingresses are imcomplete.
Checking web at url: http://cdsw.softovh.corp
Web is not yet up.
Cloudera Data Science Workbench is not ready yet

Thank you in advance for your answers.

Cloudera Employee
Posts: 39
Registered: ‎04-28-2017

Re: CDSW-Application deamon down after installation

It appears that neither node is labeled as the master node (Stateful=True) which could indicate that you have an incomplete initialization process.  I would also start with one node for simplicity and then add the second node once you get that working.  

 

Try cdsw reset on worker node and then cdsw reset on master node.  After that, try cdsw init and make sure to allow the process to complete.

 

Tristan

jkt
Explorer
Posts: 7
Registered: ‎05-17-2018

Re: CDSW-Application deamon down after installation

 

My Output from CLI commands for cdsw  is inconsistent. I don't have reset or init command.

Highlighted
Champion
Posts: 744
Registered: ‎05-16-2016

Re: CDSW-Application deamon down after installation

Could you share the logs ? 

fire the below command . 

 

cdsw logs
Announcements