Reply
New Contributor
Posts: 5
Registered: ‎08-10-2017

Deployment Cloudera Director on Azure cloud failed

Hi,

 

We’ve tried to deploy Cloudera Director from Azure market place.

Azure Cloudera Director installed properly.

But Deployment failed to create bootstrap server with below errors

 

Capture.PNG

 

Error message

 

"code": "Conflict",

"message": "{\r\n  \"status\": \"Failed\",\r\n  \"error\": {\r\n    \"code\": \"ResourceDeploymentFailure\",\r\n    \"message\": \"The resource operation completed with terminal provisioning state 'Failed'.\",\r\n    \"details\": [\r\n      {\r\n        \"code\": \"VMExtensionProvisioningError\",\r\n        
\"message\": \"VM has reported a failure when processing extension 'bootstrapServer'. 
Error message: \\\"Enable failed: failed to execute command: command terminated with exit status=1\\\".\"\r\n      }\r\n    ]\r\n  }\r\n}"

 /var/log/cloudera-director-server/application.log

 

[2017-08-24 09:23:17.420 -0500] ERROR [qtp1739202161-15] 0e34159d-f447-4c18-8e6e-b16aa55db54b POST /api/v5/environments/Director_Azure_Deployment%20Environment/templates/instances - - c.c.l.a.c.ValidationExceptionHandler: Found validation issues
com.cloudera.launchpad.api.common.InstanceTemplatesResource$InvalidInstanceTemplateException: Validation errors:
ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Availability Set 'asmaster' does not exist in Resource Group 'test11'. Please create the Availability Set or use an existing one.}, causes=[]}
ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Resource Group 'test11' does not exist. Please create the Resource Group or use an existing one.}, causes=[]}
ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=IMAGE 'PUBLISHER: 'cloudera', OFFER: 'cloudera-centos-6', SKU: 'CLOUDERA-CENTOS-6', VERSION: 'latest'' does not exist in Azure. Please verify the input.}, causes=[]}
ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Network Security Group 'directorvnet-nsg' does not exist within the Resource Group 'test11'. Please create the Network Security Group or use an existing one.}, causes=[]}
ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Subnet 'default' does not exist under the Virtual Network 'directorvnet'. Please create the subnet or use an existing one.}, causes=[]}
ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Virtual Network 'directorvnet' does not exist within the Resource Group 'test11'. Please create the Virtual Network or use an existing one.}, causes=[]}Conditions:
ValidationExceptionCondition{scope='azure.com.cloudera.director.azure.compute.provider.AzureComputeProvider.template', key='Optional.of(availabilitySet)', exceptionInfo='ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Availability Set 'asmaster' does not exist in Resource Group 'test11'. Please create the Availability Set or use an existing one.}, causes=[]}'}
ValidationExceptionCondition{scope='azure.com.cloudera.director.azure.compute.provider.AzureComputeProvider.template', key='Optional.of(computeResourceGroup)', exceptionInfo='ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Resource Group 'test11' does not exist. Please create the Resource Group or use an existing one.}, causes=[]}'}
ValidationExceptionCondition{scope='azure.com.cloudera.director.azure.compute.provider.AzureComputeProvider.template', key='Optional.of(image)', exceptionInfo='ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=IMAGE 'PUBLISHER: 'cloudera', OFFER: 'cloudera-centos-6', SKU: 'CLOUDERA-CENTOS-6', VERSION: 'latest'' does not exist in Azure. Please verify the input.}, causes=[]}'}
ValidationExceptionCondition{scope='azure.com.cloudera.director.azure.compute.provider.AzureComputeProvider.template', key='Optional.of(networkSecurityGroup)', exceptionInfo='ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Network Security Group 'directorvnet-nsg' does not exist within the Resource Group 'test11'. Please create the Network Security Group or use an existing one.}, causes=[]}'}
ValidationExceptionCondition{scope='azure.com.cloudera.director.azure.compute.provider.AzureComputeProvider.template', key='Optional.of(networkSecurityGroupResourceGroup)', exceptionInfo='ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Resource Group 'test11' does not exist. Please create the Resource Group or use an existing one.}, causes=[]}'}
ValidationExceptionCondition{scope='azure.com.cloudera.director.azure.compute.provider.AzureComputeProvider.template', key='Optional.of(subnetName)', exceptionInfo='ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Subnet 'default' does not exist under the Virtual Network 'directorvnet'. Please create the subnet or use an existing one.}, causes=[]}'}
ValidationExceptionCondition{scope='azure.com.cloudera.director.azure.compute.provider.AzureComputeProvider.template', key='Optional.of(virtualNetwork)', exceptionInfo='ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Virtual Network 'directorvnet' does not exist within the Resource Group 'test11'. Please create the Virtual Network or use an existing one.}, causes=[]}'}
ValidationExceptionCondition{scope='azure.com.cloudera.director.azure.compute.provider.AzureComputeProvider.template', key='Optional.of(virtualNetworkResourceGroup)', exceptionInfo='ErrorInfo{code=PROVIDER_EXCEPTION, properties={message=Resource Group 'test11' does not exist. Please create the Resource Group or use an existing one.}, causes=[]}'}

 

kindly advise at earliest.

 

Cloudera Employee
Posts: 8
Registered: ‎09-22-2016

Re: Deployment Cloudera Director on Azure cloud failed

Hi sudhanshu7,

 

It looks like the setup script could not find the Resource Group 'test11', and the supporting resources.

 

 

This is commonly due to credential information being incorrect (pane #3 "Cloudera Director setup information" of the setup process).

 

Could you double check that the input into these fields is correct:

* Azure Subscription ID

* Azure Active Directory Tenant ID

* Azure Active Directory Client ID

* Azure Active Directory Client Secret

 

 

 

New Contributor
Posts: 5
Registered: ‎08-10-2017

Re: Deployment Cloudera Director on Azure cloud failed

Hi Jason,

 

Thank-you for your quick reply !!

 

I've followed below Azure documentation link to get 

* Azure Subscription ID                    

* Azure Active Directory Tenant ID ( Directory ID )

* Azure Active Directory Client ID  ( Application ID )

* Azure Active Directory Client Secret ( Application Key's value )

 

https://docs.microsoft.com/en-us/azure/azure-resource-manager/resource-group-create-service-principa...

Created Application is also assigned to the admin user.

 

 But still showing same error, Kindly advise.

 

Cloudera Employee
Posts: 8
Registered: ‎09-22-2016

Re: Deployment Cloudera Director on Azure cloud failed

Hi sudhanshu7,

 

I'm going to have to take a look at your logs, PM'd.

New Contributor
Posts: 5
Registered: ‎08-10-2017

Re: Deployment Cloudera Director on Azure cloud failed

[ Edited ]

Hi Jason,

 

Sharing you cloudera director's application logs. kindly check below link.

 

https://codeshare.io/5Qm3rL

Cloudera Employee
Posts: 8
Registered: ‎09-22-2016

Re: Deployment Cloudera Director on Azure cloud failed

Hi sudhanshu7,

 

Thanks for those logs.

 

The deployment failed to import a set of default configs but the Cloudera Director install completeted fine - I'd suggest ignoring this error and logging in to Cloudera Director to fix any environment errors (e.g. by (a) making a new environment; or (b) editing the pre-loaded environment).

 

Can you let me know if that works.

Announcements