Reply
Highlighted
Explorer
Posts: 8
Registered: ‎01-25-2017
Accepted Solution

Failure to bootstrap cluster due to parcel error from CLI

[ Edited ]

Attempting to bootstrap a Java8 cluster from the CLI.  Everything seems to go well, and then this happens:

 

* Waiting for Cloudera Manager installation to complete .................. done
* Installing Cloudera Manager agents on all instances in parallel (20 at a time) .................................... done
* Creating CDH5 cluster using the new instances ... done
* Creating cluster: cdh-java8-test ........................................................... done
* java.lang.IllegalArgumentException: CDH=5.9.1-1.cdh5.9.1.p0.4 not found in list of all parcels. ...

 

The problem appears to be that for some reason the parcel name its looking for has an equal sign instead of a dash in it.  I'm not sure how this is happening, here's the snippet of my conf file that tells it the version (based on aws-simple.conf from Github):

 

products {
CDH: 5 # includes Impala and Spark
}

 

I do not have any parcel repo definitions in the conf file.

 

EDIT - I'm running Director 2.2.

Explorer
Posts: 8
Registered: ‎01-25-2017

Re: Failure to bootstrap cluster due to parcel error from CLI

I've found reference to a similar problem with other versions, and the naming is normal. I'm going to verify that the CM instance has access to the Internet the next time I run a deploy.
Explorer
Posts: 8
Registered: ‎01-25-2017

Re: Failure to bootstrap cluster due to parcel error from CLI

My AMI appears to have had a bad parcel preload. Removed all parcels on the AMI and deployed without incident.
Announcements