Reply
New Contributor
Posts: 1
Registered: ‎02-15-2015

phoenix-sqlline not working

When I run this it would stay and no response:

 

 

$ /usr/bin/phoenix-sqlline.py zk.prod.myserver.com:2181:/hbase
Setting property: [isolation, TRANSACTION_READ_COMMITTED]
issuing: !connect jdbc:phoenix:zk.prod.myserver.com:2181:/hbase none none org.apache.phoenix.jdbc.PhoenixDriver
Connecting to jdbc:phoenix:zk.prod.myserver.com:2181:/hbase
SLF4J: Failed to load class "org.slf4j.impl.StaticLoggerBinder".
SLF4J: Defaulting to no-operation (NOP) logger implementation
SLF4J: See http://www.slf4j.org/codes.html#StaticLoggerBinder for further details.
15/06/21 20:48:11 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
15/06/21 20:48:11 WARN impl.MetricsConfig: Cannot locate configuration: tried hadoop-metrics2-phoenix.properties,hadoop-metrics2.properties

 

 

Any idea?

 

New Contributor
Posts: 1
Registered: ‎06-26-2015

Re: phoenix-sqlline not working

Have the exact same issue. Note: Running CDH 5.4.2 w/ Kerberos enabled.
Cloudera Employee
Posts: 33
Registered: ‎07-08-2013

Re: phoenix-sqlline not working

Can you try to run just /usr/bin/phoenix-sqlline.py wit the host name without any port or path?

 

Im not saying it's the solution, but wondering it that helps.

 

Also, have you exported this before?

 

$ export JAVA_HOME=/usr/java/jdk1.7.0_67-cloudera
$ export PATH=$PATH:$JAVA_HOME/bin

New Contributor
Posts: 3
Registered: ‎10-01-2014

Re: phoenix-sqlline not working

 

cd to /etc/hbase/conf and then

 

execute the command /usr/bin/phoenix-sqlline.py zk.prod.myserver.com:2181:/hbase

Explorer
Posts: 21
Registered: ‎12-23-2014

Re: phoenix-sqlline not working

Same problem. I had tried the above way. But with no luck of running well. Please help on this. 

The regionservers are killed when I first run phoenix-sqlline but I cannot find any error messages from regionserver log. That is super weird.

Explorer
Posts: 21
Registered: ‎12-23-2014

Re: phoenix-sqlline not working

Hi, all

 

From Apache Phoenix mailing list, I finnally got a workaroud for this. 

 

 

I'm not sure why CDH 5.5.1 isn't working with Phoenix, but if you want to turn off the salting of the sequence table (and assuming you're not using sequences, or indexes on views or local indexes which rely on sequences), you can do the following:
- set client-side phoenix.sequence.saltBuckets to 0 in your hbase-site.xml (ensuring that hbase-site.xml is on your classpath).
- open an HBase shell and disable and drop the SYSTEM.SEQUENCE table.
- start sqlline connected to your cluster. At this point, the SYSTEM.SEQUENCE table will be re-created without being salted.
 
After adding the parameter in hbase-site.xml, I can get connected to phoenix now. Hope that works.
New Contributor
Posts: 1
Registered: ‎06-03-2016

Re: phoenix-sqlline not working

That worked actually. but why only after entering that directory, the command works?
Announcements

Currently incubating in Cloudera Labs:

Envelope
HTrace
Ibis
Impyla
Livy
Oryx
Phoenix
Spark Runner for Beam SDK
Time Series for Spark
YCSB