Reply
New Contributor
Posts: 5
Registered: ‎01-09-2018
Accepted Solution

Can not access cloudera WEB UI. After Installing it Successfully.

I Followed these steps :

 

First i took a server(Cent OS 6) from Google Cloud in Asia South reagion. and Executed these commands :

 

  1. sudo -i
  2. chkconfig iptables off
  3. service iptables stop
  4. setenforce 0
  5. vi /etc/selinux/config (SELINUX=disabled)
  6. init 6
  7. wget http://archive.cloudera.com/cm5/installer/latest/cloudera-manager-installer.bin
  8. chmod u+x cloudera-manager-installer.bin
  9. sudo ./cloudera-manager-installer.bin

Done! Cloudera manager installed Successfully.

But when I am trying to access http://my_public_ip:7180/ then getting timed out error.

Also i waited for almost an hour after installing cloudera(for startup settings). but again same response.

Posts: 713
Topics: 1
Kudos: 165
Solutions: 89
Registered: ‎04-22-2014

Re: Can not access cloudera WEB UI. After Installing it Successfully.

@Gaurav,

 

The first thing to check is whether the server is up and listening.

- service cloudera-scm-server status

- netstat -nap |grep 7180

 

Next, check the Cloudera Manager server log to find out if it had trouble starting.

- review /var/log/cloudera-scm-server/cloudera-scm-server.log

 

If you do find that Cloudera Manager is listening on 7180, make sure it is listening on all interfaces.

If you are getting a timed out message or a hang, that makes me suspicious that the server is coming up, but your route to that host is not working properly.  Could there be a proxy configured in your browser that cannot connect to your CM server?

You might try tcpdump or browser developer tools to find out what the client/server communication looks like.

 

I'd start with making sure the server is listening on 7180 and review the log for any exceptions or errors that look important.

 

New Contributor
Posts: 5
Registered: ‎01-09-2018

Re: Can not access cloudera WEB UI. After Installing it Successfully.

Hi @bgooley,

 

Thankyou for response.

here what i got

 1. service cloudera-scm-server status

     Running

 

 2. netstat -nap |grep 7180

 

tcp        0      0 0.0.0.0:7180                0.0.0.0:*                   LISTEN      1623/java

 

 

and it seems that all right in log file.

Highlighted
Contributor
Posts: 52
Registered: ‎01-08-2016

Re: Can not access cloudera WEB UI. After Installing it Successfully.

[ Edited ]

Hello Gaurav,

 

Please share the output of curl on http://my_public_ip:7180 from cm host itself.

 

And tcpdump from the source host.

New Contributor
Posts: 5
Registered: ‎01-09-2018

Re: Can not access cloudera WEB UI. After Installing it Successfully.

Thankyou @bgooley for the help.

 

I Just figured it out by tcpdump. now it's working.

New Contributor
Posts: 9
Registered: ‎03-26-2018

Re: Can not access cloudera WEB UI. After Installing it Successfully.

I am also facing the same issue, can you let me know how did you solve it

Posts: 713
Topics: 1
Kudos: 165
Solutions: 89
Registered: ‎04-22-2014

Re: Can not access cloudera WEB UI. After Installing it Successfully.

Hi @dewdrop,

 

Please see my initial comments in this thread.  We'll need to know more about what you try to do and what the result is.

 

Thanks,

 

Ben

New Contributor
Posts: 5
Registered: ‎01-09-2018

Re: Can not access cloudera WEB UI. After Installing it Successfully.

Hi @dewdrop,

Which Cloud Service are You using.
Have you allowed Port 7180 to access publicly?
New Contributor
Posts: 9
Registered: ‎03-26-2018

Re: Can not access cloudera WEB UI. After Installing it Successfully.

EC2 and port 7180 is open for public access

[ec2-user@ip-172-31-44-224 ~]$ netstat -na | grep 7180
tcp 0 0 0.0.0.0:7180 0.0.0.0:* LISTEN

New Contributor
Posts: 5
Registered: ‎01-09-2018

Re: Can not access cloudera WEB UI. After Installing it Successfully.

Hi @dewdrop,
It seems that you have opened the port 7180 on the EC2 Instance Firewall. But also you need to open TCP port 7180 in EC2 Security group.

How you can do this.
Go to the "Network & Security" -> Security Group settings in the left hand navigation
Find the Security Group that your instance is apart of
Click on Inbound Rules
Use the drop down and add port 7180
Click Apply.

Hope this helps!
Announcements