Reply
New Contributor
Posts: 4
Registered: ‎06-13-2016
Accepted Solution

Cloudera Agent deploying wrong configuration

Hi,

 

I'm facing problems when I change the configuration of any service via CM, because the deployed instance at /var/run/cloudera-scm-agent/process is aways created with the old configuration.

 

I have already tried `service cloudera-scm-agent clean_restart_confirmed` before to deploy the client configuration, but with no effect. The new path with the necessary files are aways with outdated configuration.

 

I rebooted the machine, but the problem persists.

What more should I do?

Highlighted
New Contributor
Posts: 4
Registered: ‎06-13-2016

Re: Cloudera Agent deploying wrong configuration

[Solved]
It was necessary to stop all roles running at the server.
kill -9 on some remaining process (sudo lsof +d /var/run/cloudera-scm-agent/process showed these processes)
I download the cloudera-scm-agent from its mirror (respecting my scenarios version)
Executed:
sudo service cloudera-scm-agent stop
sudo umount /var/run/cloudera-scm-agent/process

Reinstalled the cloudera-scm-agent package and executed:
sudo service cloudera-scm-agent clean_restart

This solved the issue.

Obs.: Some roles where unpacked at var/run/cloudera-scm-agent/process with corrupted files (e.g.. hue.ini with +8GB size and the dir path repeated many many times into it's content)
New Contributor
Posts: 4
Registered: ‎12-28-2017

Re: Cloudera Agent deploying wrong configuration

[ Edited ]

HI rafaelpecin,

 

I was struggling since 2 days...

Thank you very much for your answer.

 

 

Announcements