Reply
New Contributor
Posts: 5
Registered: ‎02-05-2016

Re: Cluster installation - The inspector failed to run on all hosts.

Hi, 

 

I was interested in this threat since I encountered similar issues in a simple cluster config.

I'm using CM5 on CentOS 7.2

The host inspector gave :

  • master1.domain; worker[1-3].domain: IOException thrown while collecting data from host: Connection refused

The point is that each hosts is using a public IP address on eth0 and a private IP address on eth1.

As you can guess, I want my cluster to use the internal IP only.

I tried several things (between each stage, I restarted cloudera-scm-agent to make sure the modification is taken into account)

 

1- I tried to make some modifications to my /etc/hosts to precise public FQDN for public IP ==> FAIL

2 - I tried to use /etc/cloudera-scm/agent/config.ini , listening_ip to listen ONLY on the private IP ==> FAIL

3 - I tried to use /etc/cloudera-scm/agent/config.ini , listening_hostname to listen ONLY on the hostname associated with the private interface ==> FAIL. 

At this stage, I can say, Cloudera agent is listening only on private interface (lsof confirmed) bue the inspector does not seem to focus on this

4 - I shut down eth0 (public interface) to disable multiple hostnames  ==> SUCCESS

 

At this stage, I wondered why 3 fails and 4 succeeded. I think this is due to the python script below used to detect the hostname instead of using the cloudera config file :

 

python -c 'import socket; \

              print socket.getfqdn(), \

                    socket.gethostbyname(socket.getfqdn())'

 

This script seem to give the fqdn for eth0 first so no luck for me.

Not sure this is the solution but the trick worked for me. It could make sense if Cloudera staff review the inspector code and make sure python code know how to use the config file.

 

 

 

 

Explorer
Posts: 9
Registered: ‎11-27-2017

Re: Cluster installation - The inspector failed to run on all hosts.

this fixed my problem with /etc/hosts

 

#internal.ip local.hostname
192.168.1.2 testserver
192.168.1.3 testnode

 

#public.ip public.hostname

#https://www.whatismyip.com/reverse-dns-lookup/
x.x.x.x testserver.wherever.com

 

hope this helps someone else.

Highlighted
New Contributor
Posts: 4
Registered: ‎12-28-2017

Re: Cluster installation - The inspector failed to run on all hosts.

try add allow port on firewalld on host, this solved my prob

$ firewall-cmd --zone=public --add-port=9000/tcp

(Centos7)

or $ service firewalld disable

Hope this may help

Announcements