Reply
Highlighted
Explorer
Posts: 13
Registered: ‎10-20-2016

Disabling local job execution.

[ Edited ]

Hey All,

 

Curious to find out why local jobs are still created when the values below are set as follows:

 

hive.exec.mode.local.auto=false (default)
hive.exec.mode.local.auto.input.files.max=4 (default)

 

Seems like hive.exec.mode.local.auto should disable any local jobs from running.  Yet they still do if hive.exec.mode.local.auto.input.files.max > 0 .

 

Why is that?  According to the code, appears they shouldn't be triggered anymore if hive.exec.mode.local.auto=false:

 

https://github.com/apache/hive/blob/master/ql/src/java/org/apache/hadoop/hive/ql/exec/mr/MapRedTask....

 

Cheers,

Tom

Announcements