Reply
New Contributor
Posts: 5
Registered: ‎12-03-2017

Failed to execute command Install Oozie ShareLib on service Oozie

[ Edited ]

Hello everybody. I am new in that area, and i have some problems with the installation.

I am trying to install CDH with Cloudera Manager on the cluster with 7 servers.

Inspection of all servers was successful

inspector.jpg

 

so i can't understand why i get that problem

 

oozie.jpg

 

Information from log's:

1 14:31:13 +05 2017
Current working directory: /run/cloudera-scm-agent/process/142-oozie-OOZIE-SERVER-upload-sharelib
Launching one-off process: /usr/lib/cmf/service/oozie/oozie.sh install-sharelib oozie-sharelib-yarn.tar.gz hdfs://hdps6.ugatu.com:8020 775 /user/oozie
1 14:31:13 +05 2017
JAVA_HOME=/usr/lib/jvm/java-7-oracle-cloudera
using 5 as CDH_VERSION
CONF_DIR=/run/cloudera-scm-agent/process/142-oozie-OOZIE-SERVER-upload-sharelib
CMF_CONF_DIR=/etc/cloudera-scm-agent
Exit code: 1
Error: gzip: /usr/lib/oozie/oozie-sharelib-yarn.tar.gz: No such file or directory
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors

Stack trace for the error was (for debug purposes):
--------------------------------------
ExitCodeException exitCode=2: gzip: /usr/lib/oozie/oozie-sharelib-yarn.tar.gz: No such file or directory
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors

at org.apache.hadoop.util.Shell.runCommand(Shell.java:604)
at org.apache.hadoop.util.Shell.run(Shell.java:507)
at org.apache.hadoop.util.Shell$ShellCommandExecutor.execute(Shell.java:789)
at org.apache.hadoop.fs.FileUtil.unTarUsingTar(FileUtil.java:678)
at org.apache.hadoop.fs.FileUtil.unTar(FileUtil.java:654)
at org.apache.oozie.tools.OozieSharelibCLI.run(OozieSharelibCLI.java:144)
at org.apache.oozie.tools.OozieSharelibCLI.main(OozieSharelibCLI.java:67)
--------------------------------------

+ UPLOAD_SUCCESS=1
+ '[' 1 -ne 0 ']'
+ exit 1

When i click to the continue button I see that all services except the Oozie and Spark are running (and have a Concernging healths). But when i restart the cluster - Oozie and Spark is running with all services and all of them have a concernging health (i think its due to slow network interface speed between the servers, but may be i am wrong).

 

Please, tell me what I need to do to make the cluster work fine. And how to understand the situation with Oozie? Why it's not installed, but after restarting of the cluster it's running?

 

About Cluster installation options that i choose:

1) Use Packages

2) CDH5

3) CDH 5.13.0

installation.jpg

All the rest (including role assignments) by default.

 

About OS and servers:

 

Servers: HP ProLiant DL380 and 360 G4 and G4p 

OS on servers: Ubuntu 16.04

 

Announcements