Reply
Highlighted
Explorer
Posts: 6
Registered: ‎06-15-2016

How to get rid of the "Altus Data Collection configuration" error message

I've installed a brand new 5.13, but I'm getting this configuration error message:

 

"Altus Data Collection Account must be configured to enable collection for any Altus service."

 

I don't want any Altus configuration on this server as it's an internal cluster.

 

I can't find where to fix this configuration error or even supress the error message. Can someone please help?

New Contributor
Posts: 3
Registered: ‎10-10-2017

Re: How to get rid of the "Altus Data Collection configuration" error message

Greetings Doug,

 

I just ran into this same issue and resolved it. I wanted to give you some context first. 

 

The Telemetry Publushing Service is not a necessary component of a Cloudera cluster deploy - it is to supplement an add-on service called "Workload Experience Manager or Workload XM".  

 

You can safely delete the service and it will not affect cluster operations

 

If Workload XM is a functionality you wish to leverage then you will need to take a couple steps to enable the Telemetry Publisher to send telemetry to Cloudera. 

 

Here is the Guide I Followed: 

https://www.cloudera.com/documentation/wxm/latest/topics/wxm_setup.html 

 

Step 1. Get Altus Credentials

Step 2. Add Altus Credentials to Cloudera Manager

Step 3. Add the Telemetry Publisher Service Role

 

Basically you need to log into your Altus account and generate a key pair for WXM to leverage - you will then need to add this account in Cloudera Manager as an external account under the altus tab. That can be done here. https://altus.cloudera.com/wxm/home.html#/ 

 

 

 

Next in Cloudera Manager:

Administration -> External Accounts -> click "Altus Credentials" tab and add the account. 

 

You may need to configure the account as your Altus account in Administration -> Settings -> "Telemetry Altus Account"

 

The docs don't say this but I had to restart Cloudera Manager to get this setting to take effect - I could not start the Telemetry Publisher until after I restarted Cloudera Manager

 

To access Workload XM, perform the following steps:

 

Log in to the Workload XM console: wxm.cloudera.com/

 

 

 

 

 

Announcements