Reply
Highlighted
Explorer
Posts: 8
Registered: ‎04-23-2018

Http status 401 Authentication Error:

Hello There,

 

 

I'm getting the error while login into the namenodeUI, ResourcemanagerUI, JobhistoryserverUI. I have checked the httpd service it is up and running. I have checked the port it is listening. Please tell me the solution for this. need to check the NamenodeUI.

 

Error:

 

HTTP ERROR 401

Problem accessing /index.html. Reason:

org.apache.hadoop.security.authentication.util.SignerException: Invalid signed text:


Powered by Jetty://

 

Thanks & regards,

krishna.

Contributor
Posts: 36
Registered: ‎02-23-2018

Re: Http status 401 Authentication Error:

Hi, 

 

That would mean that your browser is not configured to perform Kerberos authentication. Then you'll need to follow this link to enable Kerberos support in browser.

 

 

Regards,

Manu.

Explorer
Posts: 8
Registered: ‎04-23-2018

Re: Http status 401 Authentication Error:

The browser is working fine for different cluster (Cluster1) namenode. Cluster 1 namenode is working fine on the browser i can see the namenode web UI. But coming to Cluster2 Namenode is getting some error.

Posts: 713
Topics: 1
Kudos: 165
Solutions: 89
Registered: ‎04-22-2014

Re: Http status 401 Authentication Error:

@krishnap,

 

Two things must be in place in order for your browser to performa authentication via SPNEGO to the UIs:

 

(1)

 

The browser must be able to access kerberos credentials (TGT)

 

(2)

 

The browser must be configured to allow Kerberos authentication to the hosts to which you are connecting. 

 

It sounds as if your browser may be configured to allow authentication to one set of hosts but not another.  I recommend checking to make sure your browser is configured as described in the link that @manuroman provided in the previous response.

 

Explorer
Posts: 8
Registered: ‎04-23-2018

Re: Http status 401 Authentication Error:

Hello @bgooley,

 

thanks for the reply, i have tried in different browser (chrome and safari), but no luck. follwed the steps that are in the @manuroman link. changed the configuration and restarted the browser. still i'm getiing error.

 

Error:

HTTP ERROR 401

Problem accessing /index.html. Reason:

 

Powered by Jetty://

 

Please let me know if you need any details:

 

One Quick Question -- is there any change of solving the issue by restart the Namenode or Cloudera manager (whole cluster restart)will that works if any.

 

Thanks & Regards,

Krishna

Announcements