Reply
rio
Explorer
Posts: 48
Registered: ‎04-18-2014

Re: Issue while installing Hadoop

I ran:

 

$ service iptables stop
$ chkconfig iptables off

 

Rebooted computer.

 

I then went to cloudera manager and saw:

 

Unable to issue query: the Host Monitor is not running

 

Log files in /var/log are:

 

-rw-r--r-- 1 root root 81364 Apr 29 08:54 dmesg.old
drwxr-x--- 2 cloudera-scm cloudera-scm 4096 Apr 29 09:33 cloudera-scm-server
-rw-r--r--. 1 root root 146292 Apr 29 10:11 lastlog
-rw-r--r-- 1 root root 57064 Apr 29 11:39 Xorg.0.log.old
-rw-r--r-- 1 root root 81364 Apr 29 11:40 dmesg
-rw-------. 1 root root 22879 Apr 29 11:40 maillog
-rw-r--r-- 1 root root 3015 Apr 29 11:40 boot.log
drwxrwx--T. 2 root gdm 4096 Apr 29 11:40 gdm
-rw-r--r--. 1 root root 89 Apr 29 11:40 pm-powersave.log
-rw-------. 1 root utmp 1536 Apr 29 11:40 btmp
-rw-------. 1 root root 15168 Apr 29 11:50 cron
-rw-------. 1 root root 1764447 Apr 29 11:54 messages
-rw-r--r-- 1 root root 51111 Apr 29 11:54 Xorg.0.log
-rw-------. 1 root root 72174 Apr 29 11:54 secure
-rw-rw-r--. 1 root utmp 129792 Apr 29 11:54 wtmp

 

Which one should I look at?

 

Has it something to do with installing the Hadoop on node-1.mycluster.internal? After running the cludera binary file it told me to go to "http://localhost:7180/". But I went to "http://node-1.mycluster.internal:7180/cmf/home"

rio
Explorer
Posts: 48
Registered: ‎04-18-2014

Re: Issue while installing Hadoop

I am reinstalling the Cloudera Hadoop again. During Cluster Installation step it says:


Cloudera recommends setting /proc/sys/vm/swappiness to 0. Current setting is 60. Use the sysctl command to change this setting at runtime and edit /etc/sysctl.conf for this setting to be saved after a reboot. You may continue with installation, but you may run into issues with Cloudera Manager reporting that your hosts are unhealthy because they are swapping. The following hosts are affected:

node-1.mycluster.internal

 

Highlighted
Cloudera Employee
Posts: 79
Registered: ‎08-29-2013

Re: Issue while installing Hadoop

You will not need to reinstall again, it's best to continue with what's in place and get it fixed rather than reintroducing new work I'd say.

 

vm.swappiness can be set on-the-fly to apply for the current VM run, and also configured to be persistent across reboots. The Host Inspector check tells you how to do so.

 

- # echo 0 > /proc/sys/vm/swappiness to apply for now

- # sysctl -w vm.swappiness=0  to make this persistent across reboots.

Announcements