Reply
Highlighted
Contributor
Posts: 48
Registered: ‎05-30-2015
Accepted Solution

My Cluster CPU always stays at 80% when nothing is running

Hi everyone,

 

I have an cluster which nothing is running currently, however the CPU usage always stay at 80%, any idea what else can I check?

 

 

Posts: 923
Topics: 1
Kudos: 214
Solutions: 116
Registered: ‎04-22-2014

Re: My Cluster CPU always stays at 80% when nothing is running

@yongie,

 

If you are seeing 80% CPU in the Cluster CPU chart, expand that chart and take a closer look at what host or hosts are reporting the highest cpu.  Then you can go look at the charts for those hosts and find out if CDH processes may be responsible for the cpu.

 

Also you can use tools like "top" to look at what processes are taking the most CPU.

 

cpu_percent_across_hosts takes into account cpu % over all your hosts; it is not only explaining what CDH roles are using.

Contributor
Posts: 48
Registered: ‎05-30-2015

Re: My Cluster CPU always stays at 80% when nothing is running

Thanks for the reply,

 

I have checked, all 3 datanodes are having 100% cpu in the chart, when I log in to the host through terminal and run top command, yarn is responsible for the cpu usage, all 3 datanodes is having 400% cpu utilisation by yarn.

Expert Contributor
Posts: 62
Registered: ‎02-23-2018

Re: My Cluster CPU always stays at 80% when nothing is running

Hi @yongie,

 

You have two options:

 

1) Assign more resources to the Yarn Service if you have them availables.

2) Kill all process that are using CPU in this case YARN

 

 

Regards,

Manu.

Contributor
Posts: 48
Registered: ‎05-30-2015

Re: My Cluster CPU always stays at 80% when nothing is running

@manuroman

 

I rebooted the 3 datanodes, now it is clear.

 

Thank you!

Announcements