Reply
Champion
Posts: 424
Registered: ‎05-16-2016

Re: zookeeper error during installation in Install Path A

Would you be able to perform a tail -f command and post the logs

also this post is simliar to your issue i dont know if that is going to help you meantime .

they there is a internal jira . Not sure if they fixed it .

I usually dont choose single user mode when i go for Path A installation for POC or testing .

 

http://community.cloudera.com/t5/Cloudera-Manager-Installation/Cloudera-Single-User-Mode-installatio...

Explorer
Posts: 27
Registered: ‎07-11-2017

Re: zookeeper error during installation in Install Path A

I was also facing the same issue. This is bound to fail, looks like a bug bcoz of 'zookeeper' user absence. 

 

What you should do ? 

Ans - Go to cloudera manager page and start zookeeper from there, it will start without issue. I think you may need to create logging directory for zookeper explicitly.

Explorer
Posts: 8
Registered: ‎05-12-2017

Re: zookeeper error during installation in Install Path A

Hey Vikash,

It may start without any issue, but, what about the rest of the services? I
will need those deployed as well, and the zookeeper installation is just
the 3rd step, out of the whole deployment.

Also, you think you need to have the folder created, or are you sure about
it.

Will do a tail -f in the next days, and will post the results in here.

Thanks,
Radu
Highlighted
Explorer
Posts: 27
Registered: ‎07-11-2017

Re: zookeeper error during installation in Install Path A

As of now I don't think there is another way for single user. Yes, you need to deploy other services one by one. 

 

I am sure you will need to create directory explicitly and for all other services too at least for single user.

 

 

Please post the log at your convenience but I don't think that is going to solve the issue. The issue is there for long time I found while googling at least for community edtion.

Announcements