New Contributor
Posts: 2
Registered: ‎07-17-2017

Migrating Cloudera Navigator metadata server from MYSQL to ORACLE

[ Edited ]

Hi Team,


I want to Migrate Cloudera Navigator metadata server from MYSQL to ORACLE without deleting the role and then adding. 


I tried changing below fields values.
Database hostname
Database type
Database name


Initially got Solr error
cursorMark should accept sort param without explicit uniqueKey, do implicit uniqueKey tie breaker sort under the hood

tried deleting index files and restarted the navigator roles. 


Got below error after removing /var/lib/cloudera-scm-navigatore


2017-11-26 10:01:53,041 ERROR com.cloudera.nav.pushextractor.spark.SparkPushExtractor [qtp1860886124-63]: com.cloudera.nav.pushextractor.spark.SparkPushExtractor Error extracting Spark operation.
2017-11-26 10:01:53,041 WARN com.cloudera.nav.api.ApiExceptionMapper [qtp1860886124-63]: Unexpected exception.

and Frontend was saying access denied.


Got below error after disabling SSL

Task DeniedAccesses is reading past data set from Mon Oct 09 23:59:59 CDT 2017 to Tue Oct 10 23:59:59 CDT 2017 for the service impala by task DeniedAccesses
2017-11-28 05:19:29,427 INFO [pool-10-thread-3]: Denied Access ETL Task has no new rows for processing.


Can someone provide me steps to Migrating Cloudera Navigator metadata server from MYSQL to ORACLE?

New solutions