Reply
New Contributor
Posts: 5
Registered: ‎12-04-2014

Unable to get the Navigator API documentation.

Hi,

I tried to get the API documenation by following the steps given in below link,

http://www.cloudera.com/content/cloudera/en/documentation/core/latest/topics/navigator_data_mgmt.htm...

 

But i couldn't get the documnetation, also i got a Page not found error when i tried to hit the

"http://Navigator_Metadata_Server_host:port/api-console/index.html" url

and a blank pagewhen i tried to hit the

"http://Navigator_Metadata_Server_host:port/api/v5" url.

 

Can you please give me the right steps to get the API documentation?

 

 

Regards,

Arjun.

 

Arjun Dabhade
Highlighted
Cloudera Employee Sue
Cloudera Employee
Posts: 44
Registered: ‎09-11-2015

Re: Unable to get the Navigator API documentation.

Hi Arjun, I checked the page, here's the pertinient part:

 

Cloudera Navigator Data Management Component API

... The API is available at http://Navigator_Metadata_Server_host:port/api/v5, where Navigator_Metadata_Server_host is

the name of the host on which you are running the Navigator Metadata Server role and port is the port configured for the role.

The default port of the Navigator Metadata Server is 7187.

For API documentation go to Navigator_Metadata_Server_host:port/api-console/index.html.

 

So, it looks like what you need to do is to replace:

1. <Navigator_Metadata_Server_host> with your host name

2. <port> with the port you used, or if you left the default port, just plug in 7187 here

 

 

New Contributor
Posts: 5
Registered: ‎12-04-2014

Re: Unable to get the Navigator API documentation.

Hi Sue,

I had replaced the <Navigator_Metadata_Server_host> with my host name i.e "quickstart.cloudera" in my case and <port> to "7187".

For my navigator UI, the URL "quickstart.cloudera:7187" works and the cloudera navigator home page comes up, but when i try to hit the

URL "quickstart.cloudera:7187/api-console/index.html"  i get a HTTP 404 ERROR, Page not Found and when i try to hit the

URL "quickstart.cloudera:7187/api/v5" i get a blank page.

 

 

Regards,

Arjun.

Arjun Dabhade
Announcements
New solutions