Reply
Explorer
Posts: 12
Registered: ‎06-15-2018

Sqoop Workflow Failed: Missing Hive MetaStore connection URI

[ Edited ]

sqoop import -D mapred.job.queue.name=root.ficc.qar  -D mapreduce.map.memory.mb=3072 -D mapreduce.map.java.opts=-Xmx3072m --connect "jdbc:oracle:thin:@aoh-156n-001.sdi.corp.cmpny.com:49125:DBName" --table TRAINING_DATA_SET --username xxxxxxx --password-file /user/a101/pwd --split-by CUSIP -m 10 --hive-import --hive-database HDB --hive-table Training_Data_Set --compress --compression-codec org.apache.hadoop.io.compress.SnappyCodec --as-parquetfile

 

 


2018-06-15 10:17:15,932 [main] WARN org.kitesdk.data.spi.hive.MetaStoreUtil - Aborting use of local MetaStore. Allow local MetaStore by setting kite.hive.allow-local-metastore=true in HiveConf 2018-06-15 10:17:15,932 [main] ERROR org.apache.sqoop.tool.ImportTool - Import failed: Missing Hive MetaStore connection URI

 

Highlighted
Champion
Posts: 746
Registered: ‎05-16-2016

Re: Sqoop Workflow Failed: Missing Hive MetaStore connection URI

Are you trying to fire sqoop job using Oozie ? 

Explorer
Posts: 12
Registered: ‎06-15-2018

Re: Sqoop Workflow Failed: Missing Hive MetaStore connection URI

Yes that's correct

Announcements
New solutions