Reply
New Contributor
Posts: 6
Registered: ‎06-23-2017
Accepted Solution

can not install kudu-python

I have been struggling to install kudu-python on Centos 7 without success. 

 

The following are the commands:

 

sudo yum install kudu-client0
sudo yum install kudu-client-devel
sudo yum install -y kudu
pip install kudu-python

 

The error message:

 

gcc -pthread -B /home/fayw/anaconda2/compiler_compat -Wl,--sysroot=/ -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O 3 -Wall -Wstrict-prototypes -fPIC -I/usr/include -I/home/fayw/anaconda2/include/python2.7 -c kudu/client.cpp -o build/temp. linux-x86_64-2.7/kudu/client.o
cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++ [enabled by default]
kudu/client.cpp:589:30: fatal error: kudu/util/int128.h: No such file or directory
#include "kudu/util/int128.h"
^
compilation terminated.
error: command 'gcc' failed with exit status 1

 

 

Any help is highly appreciated!!

 

Posts: 1,697
Kudos: 342
Solutions: 265
Registered: ‎07-31-2013

Re: can not install kudu-python

The problem appears to stem from a version incompatibility. The kudu-python's latest release in PyPI is 1.7.0, which references some changes that are not yet in the most recent packages available over the Kudu website (1.4.0-cdh5.12.0).

Since the installed devel packages of Kudu 1.4.x are lacking some of the new headers referenced by the Kudu Python client of 1.7.x, the error pops up.

You can install a more compatible version of kudu-python client instead, by running:

pip install Cython kudu-python==1.2.0

Where 1.2.0 is the prior release version of kudu-python and should work with the 1.4.0 devel package you have installed already.
New Contributor
Posts: 6
Registered: ‎06-23-2017

Re: can not install kudu-python

Thanks, it works!

Announcements