Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎12-18-2014
Accepted Solution

Cannot access Hue Web UI

Hi,

 

I set up a Cloudera Live test cluster.

So far everything works fine, but when I try to access the Hue Web UI (at <Hue Server IP>:8888) I get a timeout.

However, Cloudera Manager can be accessed on port 7180.

Does anyone have a solution about it?

Cloudera Employee
Posts: 435
Registered: ‎07-12-2013

Re: Cannot access Hue Web UI

Cloudera Manager is responsible for managing and monitoring Hue (among other things, of course). If you can log into Cloudera Manager the first screen you will see includes a list of all services. Hue's status will be shown with a red, yellow or green dot. You can click on the service, go to the processes tab, and see logs from stdout, stderr, and the actual "role log" (this is most likely the be what you want to see). What does it show as the status of Hue and do you see any errors in that log?

New Contributor
Posts: 3
Registered: ‎12-18-2014

Re: Cannot access Hue Web UI

Thanks for the reply Sean.

 

The strange thing is that the Hue status is indicated with a green dot.

I had a look at the mentioned log files and couldn't find any error.

Even if I try to connect to port 8888 via telnet from the console of the Hue Server it refuses the connection.

 

Cloudera Employee
Posts: 435
Registered: ‎07-12-2013

Re: Cannot access Hue Web UI

Hmm... The same server that hosts CM should also host Hue (on 8888, as you're trying) and a web server on port 80 with a "Guidance Page" with a link straight to Hue. Are you trying to connect to 8888 on the same IP as the one you can connect to Cloudera Manager on? If so, I'd be curious to know if when you look at the Hue service in CM and click on the Instances tab, if it shows the Hue server running on the host you're expecting.

New Contributor
Posts: 3
Registered: ‎12-18-2014

Re: Cannot access Hue Web UI

Ah, I think I figured out the reason for the problem:

 

There are to ethernet connections, one is public, and the other is internally used by the cluster.

Unfortunately, the Hue webinterface is only accessible by using the IP of the internal NIC.

Do you know how I can change that?

I already tried to change the parameter "http_host" in hue.ini, but it didn't work...

 

Cloudera Employee
Posts: 435
Registered: ‎07-12-2013

Re: Cannot access Hue Web UI

If you go to the configuration tab for the Hue service and use the search
bar to search for properties with "wildcard" in the name, you should see a
property to have Hue server use a wildcard instead of binding to a specific
NIC. If that isn't checked, check it and restart the service once it's
saved. That property gets set when the service is created, so it's very
unusual that it's not getting applied for you - I haven't seen that before.
Thanks for reporting, though.

New Contributor
Posts: 3
Registered: ‎05-13-2015

Re: Cannot access Hue Web UI

Even though the thread has some time, I wanted to say that I had the same problem and that actually solved it for me.

 

Thanks!

New Contributor
Posts: 2
Registered: ‎02-14-2016

Re: Cannot access Hue Web UI

Follow the steps in the accepted solution, then use terminal to start the "hue" service with the below command,

 

sudo service hue start

New Contributor
Posts: 5
Registered: ‎11-17-2015

Re: Cannot access Hue Web UI

Even Though its a old thread. I had teh same issue. Thanks to the Solution by Sean. The issue is resolved !!

 

Key: HUE Service> Configuration >Search for Wildcard > check teh box> restart the stale service

 

No clue why its not checked by default

Explorer
Posts: 14
Registered: ‎05-22-2016

Re: Cannot access Hue Web UI

My case seems different, I didn't make any change, just stop and start and the error is gone

Announcements