Reply
New Contributor
Posts: 4
Registered: ‎05-09-2017

Configuration: Hiveserver2 & Beeline

Dear All

 

I am trying to connect Beeline with HiveServer2 and i am getting the below alert.

 

Need help to connect Beeline with HiveServer2.

 

 

[hdpsysuser@hdpmaster bin]$ beeline
which: no hbase in (/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:/home/hdpuser/.local/bin:/home/hdpuser/bin:/home/hdpsysuser/.local/bin:/home/hdpsysuser/bin:/usr/hadoopsw/hadoop-2.7.3/sbin:/usr/hadoopsw/hadoop-2.7.3/bin:/usr/hadoopsw/hive/bin:/usr/hadoopsw/db-derby-10.13.1.1-bin/bin)
Beeline version 2.1.1 by Apache Hive
beeline> show tables;
No current connection
beeline> !connect jdbc:hive2://hdpmaster:10000
Connecting to jdbc:hive2://hdpmaster:10000
Enter username for jdbc:hive2://hdpmaster:10000: hdpsysuser
Enter password for jdbc:hive2://hdpmaster:10000: **********
17/05/09 01:51:20 [main]: WARN jdbc.HiveConnection: Failed to connect to hdpmaster:10000
Error: Could not open client transport with JDBC Uri: jdbc:hive2://hdpmaster:10000: Failed to open new session: java.lang.RuntimeException: org.apache.hadoop.ipc.RemoteException(org.apache.hadoop.security.authorize.AuthorizationException): User: hdpsysuser is not allowed to impersonate hdpsysuser (state=08S01,code=0)

 

My hive-site.xml

..........................

</property>
<property>
<name>hive.server2.thrift.min.worker.threads</name>
<value>5</value>
<description>Minimum number of Thrift worker threads</description>
</property>
<property>
<name>hive.server2.thrift.max.worker.threads</name>
<value>500</value>
<description>Maximum number of Thrift worker threads</description>
</property>

<property>
<name>hive.server2.async.exec.threads</name>
<value>50</value>
</property>
<property>
<name>hive.server2.async.exec.shutdown.timeout</name>
<value>10</value>
</property>
<property>
<name>hive.support.concurrency</name>
<value>true</value>
</property>
<property>
<name>javax.jdo.option.ConnectionUserName</name>
<value>hdpsysuser</value>
<description>Username to use against metastore database</description>
</property>
<property>
<name>hive.server2.enable.doAs</name>
<value>true</value>
</property>
</configuration>

 

 

Thanks

 

Announcements