Reply
New Contributor
Posts: 2
Registered: ‎02-29-2016

ERROR when starting namenode and datanode on log4j.appender.RFA

[ Edited ]

When I start namenode : service hadoop-hdfs-namenode start

 

The outputs are : 

starting namenode, logging to /var/log/hadoop-hdfs/hadoop-hdfs-namenode-quickstart.cloudera.out
log4j:ERROR Could not find value for key log4j.appender.RFA
log4j:ERROR Could not instantiate appender named "RFA".
log4j:WARN No appenders could be found for logger (org.apache.hadoop.hdfs.server.namenode.NameNode).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
Started Hadoop namenode: [ OK ]

 

As you can see the namenode started but for the datanode : 

[root@quickstart etc]# service hadoop-hdfs-datanode start
starting datanode, logging to /var/log/hadoop-hdfs/hadoop-hdfs-datanode-quickstart.cloudera.out
log4j:ERROR Could not find value for key log4j.appender.RFA
log4j:ERROR Could not instantiate appender named "RFA".
log4j:WARN No appenders could be found for logger (org.apache.hadoop.hdfs.server.datanode.DataNode).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
Failed to start Hadoop datanode. Return value: 1 [FAILED]

 

Could anybody tell me how can I fix it ?

I'm using VMPlayer and CDH4 on Windows 7.

Thank you in advance for your help.

 

Highlighted
New Contributor
Posts: 3
Registered: ‎05-07-2017

Re: ERROR when starting namenode and datanode on log4j.appender.RFA

How did you solve this? I have just encountered the exact same problem

New Contributor
Posts: 3
Registered: ‎10-02-2017

Re: ERROR when starting namenode and datanode on log4j.appender.RFA

Hey buddy.........share across the solution you applied.
Im facing the same issue and someone else too requested below.
You will be helping 2 for sure, maybe more!
Awaiting your reply, much appreciate your help!!!
Announcements