Reply
New Contributor
Posts: 2
Registered: ‎02-29-2016

ERROR when starting namenode and datanode on log4j.appender.RFA

[ Edited ]

When I start namenode : service hadoop-hdfs-namenode start

 

The outputs are : 

starting namenode, logging to /var/log/hadoop-hdfs/hadoop-hdfs-namenode-quickstart.cloudera.out
log4j:ERROR Could not find value for key log4j.appender.RFA
log4j:ERROR Could not instantiate appender named "RFA".
log4j:WARN No appenders could be found for logger (org.apache.hadoop.hdfs.server.namenode.NameNode).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
Started Hadoop namenode: [ OK ]

 

As you can see the namenode started but for the datanode : 

[root@quickstart etc]# service hadoop-hdfs-datanode start
starting datanode, logging to /var/log/hadoop-hdfs/hadoop-hdfs-datanode-quickstart.cloudera.out
log4j:ERROR Could not find value for key log4j.appender.RFA
log4j:ERROR Could not instantiate appender named "RFA".
log4j:WARN No appenders could be found for logger (org.apache.hadoop.hdfs.server.datanode.DataNode).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.
Failed to start Hadoop datanode. Return value: 1 [FAILED]

 

Could anybody tell me how can I fix it ?

I'm using VMPlayer and CDH4 on Windows 7.

Thank you in advance for your help.

 

New Contributor
Posts: 3
Registered: ‎05-07-2017

Re: ERROR when starting namenode and datanode on log4j.appender.RFA

How did you solve this? I have just encountered the exact same problem

Explorer
Posts: 8
Registered: ‎10-02-2017

Re: ERROR when starting namenode and datanode on log4j.appender.RFA

Hey buddy.........share across the solution you applied.
Im facing the same issue and someone else too requested below.
You will be helping 2 for sure, maybe more!
Awaiting your reply, much appreciate your help!!!
New Contributor
Posts: 3
Registered: ‎11-04-2016

Re: ERROR when starting namenode and datanode on log4j.appender.RFA

I am getting below error. Can any one help me?

 

[root@quickstart init.d]# cat /var/log/hadoop-yarn/yarn-yarn-proxyserver-quickstart.cloudera.out
log4j:ERROR Could not find value for key log4j.appender.RFA
log4j:ERROR Could not instantiate appender named "RFA".
log4j:WARN No appenders could be found for logger (org.apache.hadoop.yarn.server.webproxy.WebAppProxyServer).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.

Champion
Posts: 680
Registered: ‎05-16-2016

Re: ERROR when starting namenode and datanode on log4j.appender.RFA

@HarpreetSingh @guineapig @SandyCT @rdmar

 

were you folks are not able to fire a simple hadoop fs shell command ? 

how are you starting the hdfs daemons ? 

whats the cloudera manager web ui shows about the namenode and datanode ? 

you should be able to pull us the full log trace from /var/log/ location . 

Highlighted
New Contributor
Posts: 3
Registered: ‎11-04-2016

Re: ERROR when starting namenode and datanode on log4j.appender.RFA

Error pops up when i try to start hadoop proxy server, it shows in failed state
Announcements