Reply
New Contributor
Posts: 3
Registered: ‎06-19-2017

The namenode in cloudera-vm is failing to start

Hey, I'm using Cloudera quick-start vm in a computer without access to the network, the vm is cm version 5.8.0

The pc specification is I7 6700T with 16 GB ram and 256 SSD, running 64 bit windows 7 using vmware player.

The vm is working perfectly but when i start the cluster, the name node is failing to boot! (also the secondary namenode).

I tried deleting the cluster and re applying it but the problem stays the same.

That is the most important thing i could get out of the log and i couldn't find any solution:

"the value of property bind.address must not be null"

 

Thanks in advance for any help

Champion
Posts: 543
Registered: ‎05-16-2016

Re: The namenode in cloudera-vm is failing to start

Could you share the full logs ? 

Can you check if the iptables / firewall is on ? 

what version of java are you using ? 

is the selinux is disabled ? 

Champion
Posts: 543
Registered: ‎05-16-2016

Re: The namenode in cloudera-vm is failing to start

[ Edited ]

Also if possible please share your 

hdfs-site.xml    Location - /etc/hadoop/conf/

core-site.xml - Location - /etc/hadoop/conf

 i guess you are missing 

configuration parameter on the .core-site.xml:

 

<configuration>
<property>
<name>fs.defaultFS</name>
<value>hdfs://101.100.201.168/</value>
</property>
</configuration>

 

New Contributor
Posts: 3
Registered: ‎06-19-2017

Re: The namenode in cloudera-vm is failing to start

[ Edited ]

Hey. I can't currently get files out of the vm network. if you want me to check something specific i will do it.

I really think it is because the vm is on premise 

 

It is the default vm, the iptabels is off. selinux off

java -v is giving me : Error: could not create the java virutal machine.

jdk.1.7.0_67-cloudera

 

about the core file, i do have this property but its value is hdfs://quickstart.cloudera:8020

 

I did not changed any of this files manully.

Thank you for the help.

Champion
Posts: 543
Registered: ‎05-16-2016

Re: The namenode in cloudera-vm is failing to start

Could you start your name node , and share the logs on em . 

Just want to see the full stack trace. 

Announcements