Reply
New Contributor
Posts: 2
Registered: ‎01-05-2018
Accepted Solution

failed to connect to cloudera EDH on AWS via ssh tunnel in Putty

[ Edited ]

Hello there,

 

I am fairly new with unix command. Could someone help me with this?

 

I was trying to ssh into my cloudera EDH instance, following the instruction here. I think I got the ssh established to port 7189. However, I still cannot connect to cloudera manager from my local browser, and it gives me 'refuse to connect' error.

I am running Putty on a windows machine. here is the putty log:

 

[ec2-user@ip-172-31-10-233 ~]$ ssh -i /home/ec2-user/cloudera/setup-default/main_key.pem -L 7189:localhost:7189 ec2-user@ec2-35-182-66-141.ca-central-1.compute.amazonaws.com
Last login: Fri Jan 5 14:21:06 2018 from ip-172-31-10-233.ca-central-1.compute.internal
[ec2-user@ip-172-31-10-233 ~]$ netstat -lep --tcp
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State User Inode PID/Program name
tcp 0 0 0.0.0.0:49742 0.0.0.0:* LISTEN cloudera-director 30148 -
tcp 0 0 0.0.0.0:7189 0.0.0.0:* LISTEN cloudera-director 29664 -
tcp 0 0 0.0.0.0:ssh 0.0.0.0:* LISTEN root 19193 -
tcp 0 0 localhost:smtp 0.0.0.0:* LISTEN root 16298 -
tcp6 0 0 localhost:7189 [::]:* LISTEN ec2-user 281332 4203/ssh
tcp6 0 0 [::]:ssh [::]:* LISTEN root 19195 -
tcp6 0 0 localhost:smtp [::]:* LISTEN root 16299 -

 

process 4203 is already running, I assume that is the ssh tunnel i just created? but i still cannot access to http://localhost:7189/ on chrome nor firefox. What is the issue here?

 

thank you so much for the help.

New Contributor
Posts: 2
Registered: ‎01-05-2018

Re: failed to connect to cloudera EDH on AWS via ssh tunnel in Putty

 found the solution.

1) port forwarding should be defined in the PuTTy interface: ssh ->auth->tunneling

2) need to enable the inbound rule to include TCP traffic

 

 

Announcements