Reply
Highlighted
New Contributor
Posts: 3
Registered: ‎01-31-2018
Accepted Solution

Impala ODBC Driver 2.5.5 old version?

[ Edited ]

I installed Impala ODBC 2.5.5 (the latest version) on OS X. The driver does not load from unixodbc 2.3.6. The error says 'cannot find file' even though it is pointing to the correct file and all dependencies are present. I checked the timestamp on the lib files:

 

-rwxr-xr-x  1 root  wheel       576 Sep 26  2013 SimbaImpalaODBC.did
-rwxr-xr-x  1 root  wheel  87203512 Sep 26  2013 libclouderaimpalaodbc.dylib
-rwxr-xr-x  1 root  wheel   3309240 Sep 26  2013 libcrypto.1.0.0.dylib
-rwxr-xr-x  1 root  wheel   3309240 Sep 26  2013 libcrypto.dylib
-rwxr-xr-x  1 root  wheel    769176 Sep 26  2013 libssl.1.0.0.dylib
-rwxr-xr-x  1 root  wheel    769176 Sep 26  2013 libssl.dylib

 

These are from 2013, much older than the prior release I had (2.5.22).

 

I then installed 2.5.41 and everything worked fine again.

 

If there are useful fixes in 2.5.5 it would be good to get the proper version uploaded.

Expert Contributor
Posts: 83
Registered: ‎07-17-2017

Re: Impala ODBC Driver 2.5.5 old version?

[ Edited ]

Hi  @CoryIsaacson,

Cloudera Impala ODBC v2.5.5 is the old version, in fact, I think it's the first release.
You are now using the last one 2.5.41 (october 2017).
41
> 5
;-)

Good luck.

New Contributor
Posts: 3
Registered: ‎01-31-2018

Re: Impala ODBC Driver 2.5.5 old version?

Thanks, that of course makes sense. I think I see what the issue was, the download page actually had 2.5.5 at the top (so I mistakenly thought it was the latest). Now when I checked 2.5.5 is second from the last so it's obvious it's older. Perhaps it was a glitch with the download page that day, all fine now.

Announcements