Reply
Highlighted
Explorer
Posts: 16
Registered: ‎11-14-2017
Accepted Solution

Impala ODBC settings with Kerberos

[ Edited ]

Hello,

 

We have a kerberized clúster and a user of us tells that the next setting on the ODBC for Impala is not working

 

impala <- src_impala(
  drv = drv,
  driver = "/opt/cloudera/impalaodbc/lib/64/libclouderaimpalaodbc64.so",
  host = "hostname",
  port = 21050,
  database = "publication",
  KrbRealm = "CLOUDERA",
  KrbFQDN = "hostname",
  KrbServiceName = "impala",
  AuthMech = 1,
  UseKeytab = 1,
  UPNKeytabMappingFile = "/home/gentrif/talend.keytab"
)

 

Looking into the documentation I told them to use the next setting

 

impala <- src_impala(
  drv = drv,
  driver = "/opt/cloudera/impalaodbc/lib/64/libclouderaimpalaodbc64.so",
  host = "hostname",
  port = 21050,
  database = "publication",
  KrbRealm = "CLOUDERA",
  KrbFQDN = "hostname",
  KrbServiceName = "impala",
  AuthMech = 1,
  UseKeytab = 1,
  DefaultKeytabFile = "/home/gentrif/talend.keytab"
  uid = "principal"
)

 

As the user tells us this last configuration is not working for their application.

 

Maybe we are forgeting something important.

 

Thank you in advance

Explorer
Posts: 16
Registered: ‎11-14-2017

Re: Impala ODBC settings with Kerberos

Hello everybody,

 

The settings we provided the app developers in the client side was right, they had some problem with /etc/hosts configuration making them to not authenticating properly to the KDC server, also, they had a bad /etc/krb5.conf.

 

With that I close this topic

Announcements