Reply
Explorer
Posts: 40
Registered: ‎04-13-2017

Re: Impala queries through impala JDBC is running with empty user

Interestingly, though many people in this thread are complaining of the same issue, no one has posted an error message that shows the correct syntax as outlined by the manual in the link from @Lars Volker.

 

Specifically, the manual shows the syntax for the connection string with a username (and no password) should be using AuthMech=2:

 

jdbc:impala://node1.example.com:21050;AuthMech=2;UID=impala

At least for me, this "resolved" the issue because now I am trying to debug a connection timeout.  So I guess that is progress :/

Expert Contributor
Posts: 338
Registered: ‎01-25-2017

Re: Impala queries through impala JDBC is running with empty user

@epowell Apologize me, it's my fault since i solved it using auth mechanism 6 and didn't update the thread.

Explorer
Posts: 40
Registered: ‎04-13-2017

Re: Impala queries through impala JDBC is running with empty user

AuthMech=6?  I don't see that in the manual as an option.  Can you please post your full connection string?  Thanks

Highlighted
Expert Contributor
Posts: 338
Registered: ‎01-25-2017

Re: Impala queries through impala JDBC is running with empty user

@epowell My bad, i mixed this with my issue with the impala ODBC.

 

In this issue i still unable to get it works.

 

Yes i'm passing the conf than Lars share but my issue with i change the AuthMech to 2, my queries stuck.

 

 jdbc:impala://node1.example.com:21050;AuthMech=2; UID=fawzea
 
Screen Shot 2018-10-21 at 5.17.19 PM.png
 
 
Log:
 
ERROR [2018-10-21 10:16:20,388] ({pool-2-thread-2} JDBCInterpreter.java[open]:197) - zeppelin will be ignored. driver.zeppelin and zeppelin.url is mandatory.
Explorer
Posts: 40
Registered: ‎04-13-2017

Re: Impala queries through impala JDBC is running with empty user

I cannot get it to work either.  I am trying to use the connection string within the DBbeaver database client and it just hangs forever.

Announcements