Reply
Highlighted
New Contributor
Posts: 2
Registered: ‎06-18-2018
Accepted Solution

KUDU trusted subnets does not work

After upgrade Cloudera Manager from 5.14.0 to 5.15.0 my trusted_subnets in KUDU configuration does not work. Also --trusted_subnets=0.0.0.0/0 does not work. I get an error in the impala-shell :

 

ERROR: TransmitData() to x.x.x.x:27000 failed: Not authorized: Client connection negotiation failed: client connection to x.x.x.x:27000: FATAL_UNAUTHORIZED: Not authorized: unencrypted connections from publicly routable IPs are prohibited. See --trusted_subnets flag for more information.: x.x.x.x:52167

 

My config is:

 

--trusted_subnets=0.0.0.0/0
--rpc-authentication=disabled
--rpc-encryption=disabled

Cloudera Employee
Posts: 16
Registered: ‎01-29-2016

Re: KUDU trusted subnets does not work

Hi @buddelflinktier,

 

Impala has started using KRPC for the TransmitData() RPC as well from 5.15. So you would need to configure the 'trusted_subnets' flag the same way in your Impala configuration as well (it doesn't pick it up from the Kudu configuration).

 

- Sailesh

New Contributor
Posts: 2
Registered: ‎06-18-2018

Re: KUDU trusted subnets does not work

Thanks, it works fine!

Announcements