New Contributor
Posts: 1
Registered: ‎11-01-2017

Use Hue with Impala in Docker



I have a few hadoop services running locally in my pc with Docker. I have hdfs and the impala-shell running through the command line without any issues but I am unable to make it run in Hue. 


First of all, Hue is connecting to the HDFS filesystem and I can navigate, upload or delete files in hdfs. I don't have the hive-server2 running but the Impalad is running properly and Hue is configured to connect to it to the port 21050 (the same port that appears when I connect through impala-shell).


When I open the hue with Impala, I get the following errors: 

"Ignoring invalid configuration option: idle_session_timeout"


"Bad status for request TOpenSessionReq(username=u'hue', password=None, client_protocol=6, configuration={'idle_session_timeout': '3600'}): TOpenSessionResp(status=TStatus(errorCode=None, errorMessage='Ignoring invalid configuration option: idle_session_timeout', sqlState='HY000', infoMessages=None, statusCode=3), sessionHandle=TSessionHandle(sessionId=THandleIdentifier(secret='\xc3h\x04\x1a\xde\xd9Ab\xb9b\x0f\xdf\xfe\x83\xe3\x93', guid='\x9e\x98\xe7\xa2\x8c\xa0Jg\x97%\xbaF\x1c\x87\t\x04')), configuration=None, serverProtocolVersion=4)"


This is how my hue.ini looks like:



      # Enter the filesystem uri
      # Use WebHdfs/HttpFs as the communication mechanism.
      # Domain should be the NameNode or HttpFs host.

  # Host where HiveServer2 is running.
  # Host of the Impala Server (one of the Impalad)


	# A negative number means that idle sessions will not be timed out.

I have been going on with this issue for days and I would really like to use the Hue instead of the Impala-shell to make my life easier. Is it mandatory to have the Hive-server2 running to run Impala queries?

Posts: 177
Topics: 8
Kudos: 25
Solutions: 19
Registered: ‎07-16-2015

Re: Use Hue with Impala in Docker

First :

- Why do you suspect that Hiveserver2 need to be up and running for impala query to works ? Did you observe that when running Hiveserver2 impala queries worked ?

By the way, Hivemetastore is running right ?


- Second : You should go look at hue server log files. You should see a better error.