Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 01-04-2015 11:42 PM - edited 09-16-2022 02:17 AM
hi:
cdh5.2.0 ,impala 2.0.
Every hour I will pull data from hive to impala(parquet file).Sometimes,can not excute sql like below,and restart the impala cluster could solve the problem,why?
select id,sub1,(ifnull(sum(click),0)) as clicks > from new_td_impala_test
where (part1>='2014-11-06' and part1<='2014-11-06') and (unix_timestamp(substr(time_stamp,1,19)) >= unix_timestamp('2014-10-31 16:00:00') and unix_timestamp(substr(time_stamp,1,19)) < unix_timestamp('2014-11-07 16:00:00')) group by id,sub1 limit 4 ;
Query: select id,sub1,(ifnull(sum(click),0)) as clicks
from new_td_impala_test
where (part1>='2014-11-06' and part1<='2014-11-06') and (unix_timestamp(substr(time_stamp,1,19)) >= unix_timestamp('2014-10-31 16:00:00') and unix_timestamp(substr(time_stamp,1,19)) < unix_timestamp('2014-11-07 16:00:00')) group by id,sub1 limit 4
WARNINGS: Create file /tmp/impala-scratch/7241111ac15574e0:abef55f7a589b3a5_7241111ac15574e0:abef55f7a589b3a7_dc8fc8e3-f98c-41e8-a86a-d9c8f7840cdb failed with errno=2 description=Error(2): No such file or directory
Backend 1:Create file /tmp/impala-scratch/7241111ac15574e0:abef55f7a589b3a5_7241111ac15574e0:abef55f7a589b3a7_dc8fc8e3-f98c-41e8-a86a-d9c8f7840cdb failed with errno=2 description=Error(2): No such file or directory
Created 01-05-2015 03:21 AM
Created 01-05-2015 12:40 AM
When one or more parent directories in the path are missing, file creation will fail with err=2
# ls -ld /tmp/impala-scratch
ls: cannot access /tmp/impala-scratch: No such file or directory
# touch /tmp/impala-scratch/test
touch: cannot touch `/tmp/impala-scratch/test': No such file or directory
Next time this error occurs, check for the presence of /tmp/impala-scratch before restarting the service. Also, check the HDFS Audit logs to identify which user might be deleting the directory.
Created 01-05-2015 03:21 AM
Created 06-29-2015 12:31 PM
Hi There,
Do you know, what are the steps we have to follow to make this change?
I kept on reading the page but didn't find that helpfull.
http://www.cloudera.com/content/cloudera/en/documentation/core/latest/topics/impala_disk_space.html
Created 06-30-2015 09:19 AM
I have options to add another directory but I don't know if that will skip default setting or still I will need to change default.