Reply
Explorer
Posts: 19
Registered: ‎07-24-2017

Cannot access: //. Note: you are a Hue admin but not a HDFS superuser, "hdfs" or part of HDFS superg

Hi,

I am new to Hue. I have installed Hue on the remote server than that of the namenode.
 
 
When I login to Hue and try to access the HDFS file locations, I am getting following error. 
 
Cannot access: //. Note: you are a Hue admin but not a HDFS superuser, "hdfs" or part of HDFS supergroup, "supergroup". 
 
I created the user admin and hdfs in Hue  and they are the superusers.  I have also created directories in hdfs and added to supergroup.
 
drwxr-xr-x   - hduser supergroup          0 2017-09-09 14:47 /user
drwxr-xr-x   - admin  supergroup          0 2017-09-09 14:16 /user/admin
drwxr-xr-x   - hdfs   supergroup          0 2017-09-09 14:13 /user/hdfs
drwxr-xr-x   - hduser supergroup          0 2017-09-04 17:27 /user/hduse
 
Please let me know where am I making the mistake and request to guide. 
Explorer
Posts: 19
Registered: ‎07-24-2017

Re: Cannot access: //. Note: you are a Hue admin but not a HDFS superuser, "hdfs" or part

Any body can help. 

 

my hdfs-site.xml has the following in HA NN and DN

<property>
  <name>dfs.webhdfs.enabled</name>
  <value>true</value>
</property>
</configuration>

My hue.ini has 

 [[hdfs_clusters]]
    # HA support by using HttpFs

    [[[default]]]
      # Enter the filesystem uri
      fs_defaultfs=hdfs://ha-cluster

      # NameNode logical name.
      ## logical_name=

      # Use WebHdfs/HttpFs as the communication mechanism.
      # Domain should be the NameNode or HttpFs host.
      # Default port is 14000 for HttpFs.
      ## webhdfs_url=http://localhost:50070/webhdfs/v1
       webhdfs_url=http://<gateway_host_name>:14000/webhdfs/v1

My httpFs-site.xml has

  <!-- HUE proxy user setting -->
  <property>
    <name>httpfs.proxyuser.hue.hosts</name>
    <value>*</value>
  </property>
  <property>
    <name>httpfs.proxyuser.hue.groups</name>
    <value>*</value>
  </property>

  <property>
    <name>httpfs.hadoop.config.dir</name>
    <value>/etc/hadoop/conf</value>
  </property>
</configuration>
New Contributor
Posts: 3
Registered: ‎05-22-2018

Re: Cannot access: //. Note: you are a Hue admin but not a HDFS superuser, "hdfs" or part

Hello Sandy, I'm currently facing the same issue now. Did you figured out how can you solve this error ! If yes, please share those details as it would be very helpful for us.

 

Thanks

Suraj

Explorer
Posts: 19
Registered: ‎07-24-2017

Re: Cannot access: //. Note: you are a Hue admin but not a HDFS superuser, "hdfs" or part

Hi Siraj,

I did not find the solution for this.

This was the issue with the manual setup. When I used cloudera package
installation all worked fine.
Highlighted
New Contributor
Posts: 3
Registered: ‎05-22-2018

Re: Cannot access: //. Note: you are a Hue admin but not a HDFS superuser, "hdfs" or part

[ Edited ]

Oh Ok, Thank you Sandy. I'm actually running the Hue instance in EMR cluster, so I think I can't apply any changes here with cloudera packages. 

 

Cloudera support team, if you have a possible solution for this please leave your comments. I could see this issue was raised by several developers but there were no apt solutions on this.

 

Cannot access: /user/. The HDFS REST service is not available.

HTTPConnectionPool(host='ip-XX-XX-XX-XX.ec2.internal', port=50070): Max retries exceeded with url:

 

Thanks

Suraj

 

 

Announcements