Reply
Highlighted
Explorer
Posts: 24
Registered: ‎10-18-2017
Accepted Solution

Do not see impala app in hue after installation of impala.

[ Edited ]

Hi,

I installed the cloudera manager and a small cluster. Hive through hue is working fine. Then I added the impala service. This is running fine (everything green in the cloudera manager). I want to add it now to hue so I can also run queries using impala. From what I read online, I should see the impala app under desktop/dump_config but this is not the case. I am running cloudera manager 5.13 .

When I check /run/cloudera-scm-agent/process I do notice in the hue.ini file that app_blacklist contains impala. However in the /etc/hue/conf/hue.ini file this is not the case. Also when I navigate to confiugration through cloudera manger, nothing is filled for the blacklist. WHat I understand from it , is that the app blacklist only prevents these apps listed from showing up in the standard hue web page top bar.

Maybe should I have changed something in the default configuration of impala before it is usable through hue? What does work fine is when I start the impala-shell command in Linux, so I thin impala was correctly installed.


Any idea how to add impala to hue so I can use it as a query editor?

 

Many thanks,

JB

Posts: 713
Topics: 1
Kudos: 165
Solutions: 89
Registered: ‎04-22-2014

Re: Do not see impala app in hue after installation of impala.

Hello @JB0000000000001,

 

If you added the Impala Service after Hue was part of the cluster, it is likely you need to manually enable Impala via Cloudera Manager.

 

Try going to Hue --> Configuration

Then, search for "Impala Service"

 

If "none" is selected, choose the name of your Impala service instead and save.

Restart Hue.

Log out of Hue and back in if you already have an active session just to be sure.

 

After that, Impala service should be available in Hue.

 

 

Explorer
Posts: 24
Registered: ‎10-18-2017

Re: Do not see impala app in hue after installation of impala.

Indeed, this is exactly what was missing. Many thanks for prompt response.

Announcements