Reply
Explorer
Posts: 11
Registered: ‎04-18-2016

Hue WebUI users missing after CM/CDH upgrade from 5.4.4 to 5.15

Greetings,

 

We have upgraded CM/CDH from 5.4.4 to 5.15. Everything passed OK.

 

It seems that the HUE WebUI is missing now (after upgrade) all the users information. Even the admin (supersuser) is missing, and asks to be re-created.

 

Is there a solution/workaround for that situation ?

 

regards,

Avi

 

Posts: 519
Topics: 14
Kudos: 90
Solutions: 45
Registered: ‎09-02-2016

Re: Hue WebUI users missing after CM/CDH upgrade from 5.4.4 to 5.15

@tavi99

 

Not sure you are getting the user info from ldap/ad or database, or some other

 

1. CM -> Hue-> config -> Authentication Backend
   a. if you are using ldap then it should be "desktop.auth.backend.LdapBackend"
   b. if you are using database then it should be "desktop.auth.backend.AllowFirstUserDjangoBackend"

 

2. CM -> Administration (menu) -> Settings -> search for ldap
   a. "Authentication Backend order" -> choose 'External then database'
   b. make sure your ldap configuration is updated as needed

 

NOTE: Before you make any changes/overwrite your config, pls make sure to take a backup

 

Pls try this, it may help you

Explorer
Posts: 11
Registered: ‎04-18-2016

Re: Hue WebUI users missing after CM/CDH upgrade from 5.4.4 to 5.15

Hello

 

Many thanks for the answer.

 

We don't use LDAP neither AD for users storage.

So we keep them in the default Hue database.

Indeed we have the "desktop.auth.backend.AllowFirstUserDjangoBackend" value set for Authentication Backend .

 

Any advices as per our configuration ?

 

regards

 

Posts: 519
Topics: 14
Kudos: 90
Solutions: 45
Registered: ‎09-02-2016

Re: Hue WebUI users missing after CM/CDH upgrade from 5.4.4 to 5.15

@tavi99

 

What about this?

 

CM -> Administration (menu) -> Settings -> search for 
   a. "Authentication Backend order" -> choose 'External then database'

Explorer
Posts: 11
Registered: ‎04-18-2016

Re: Hue WebUI users missing after CM/CDH upgrade from 5.4.4 to 5.15

When i search through  CM -> Administration menu -> Settings

for LDAP - i get only two/following results:

- Kerberos        Active Directory LDAPS Port 

- Parcels          Create Users and Groups, and Apply File Permissions for Parcels

 

As you see - no "Authentication Backend order" values here.

 

 

 

Explorer
Posts: 11
Registered: ‎04-18-2016

Re: Hue WebUI users missing after CM/CDH upgrade from 5.4.4 to 5.15

The only way to see the settings of "Authentication Backend" - is :

goto Hue=>Configuration and search for "Authentication Backend".

 

There we have the following possibilities:

desktop.auth.backend.SpnegoDjangoBackend
django.contrib.auth.backends.ModelBackend
desktop.auth.backend.AllowFirstUserDjangoBackend
desktop.auth.backend.LdapBackend
desktop.auth.backend.AllowAllBackend
desktop.auth.backend.PamBackend

 

and the default value "desktop.auth.backend.AllowFirstUserDjangoBackend" is set.

 

 

Posts: 954
Topics: 1
Kudos: 226
Solutions: 121
Registered: ‎04-22-2014

Re: Hue WebUI users missing after CM/CDH upgrade from 5.4.4 to 5.15

@tavi99,

 

My guess is that your database was changed in Hue.  In recent releases we no long user sqlite by default so if you were using sqlite before, I wonder if you see that Hue is configured for another database now.

 

In Cloudera Manager, go to your Hue configuration and look at the Database settings.

If you are not sure, you can check "History and Rollback" link on that page to see recent changes that may have been made (even by wizards, upgrade, etc.)

 

-Ben

Posts: 954
Topics: 1
Kudos: 226
Solutions: 121
Registered: ‎04-22-2014

Re: Hue WebUI users missing after CM/CDH upgrade from 5.4.4 to 5.15

**** NOTE:  backend configuration defines how auth is done, not what users are visible in the Hue UI.  If Hue asked you to create an admin account again, that means it has a fresh database.

Explorer
Posts: 11
Registered: ‎04-18-2016

Re: Hue WebUI users missing after CM/CDH upgrade from 5.4.4 to 5.15

We did use SQLite3 as Hue database in Cloudera 5.4.4.

Before the upgrade - we've made a backup of that database (as from /var/lib/hue/desktop.db).

 

After the upgrade - when tried to Login to Hue WebUI - have been asked to create a new user.

Reason - unknown. Indeed it could be that upgrade to 5.15 had some impact to the Hue database.

 

So, have stopped Hue and just replaced the Hue database file - with the backed up before 5.4.4 db file, and then started Hue.

This seems to work , and although there were some warnings, Hue seems to "know" the defined before users and permissions.

As for now - in Hue Configuration Database settings arrear SQLite3, and it seems to work.

 

The questions are:

1. What is the proper way to care about Hue database while upgrading from 5.4.4 to 5.15 ?

2. Shall we expect for some negative impat after processing the Hue database (restored from 5.4.4) as described above ?

 

Best regards and looking forward your assistance

 

 

Cloudera Employee
Posts: 717
Registered: ‎07-30-2013

Re: Hue WebUI users missing after CM/CDH upgrade from 5.4.4 to 5.15

This should not happen. What database are you using? Are you also using the
LDAP backend?
Announcements