Reply
Highlighted
Explorer
Posts: 10
Registered: ‎03-17-2016

Hue oozie integration not working in secure mode

Hello,

 

I am integrating hue with oozie in secure mode. I see in the logs that hue is making call to oozie and getting the proxyuser cannot be null error and other settings that should be present in oozie-site.xml. These settings are already present in my oozie site.xml and oozie is working fine. I debugged further and found that if I add a param to the url that hue is submitting to oozie, it works.

 

Url that hue is using 

===============

http://192.168.33.21:11000/oozie/v1/jobs?len=50&doAs=akabra&filter=status%3DRUNNING%3Bstatus%3DPREP%...

 

Error response that hue is recieving

===========================

proxyUser cannot be null, If you're attempting to use user-impersonation via a proxy user, please make sure that oozie.service.ProxyUserService.proxyuser.#USER#.hosts and oozie.service.ProxyUserService.proxyuser.#USER#.groups are configured correctly

 

Error is getting removed if I add the param "user.name=oozie" to the url

======================================================

http://192.168.33.21:11000/oozie/v1/jobs?len=50&doAs=akabra&filter=status%3DRUNNING%3Bstatus%3DPREP%...

 

My hue.ini settings

==============

[liboozie]
oozie_url=http://localhost:11000/oozie

security_enabled=true

remote_deployement_dir=/user/oozie/deployments

 

Questions

1) Is there any setting that I am missing in hue.ini ?

2) Does hue oozie integration in secure mode works ?

 

Amit.

 

 

 

 

Explorer
Posts: 10
Registered: ‎03-17-2016

Re: Hue oozie integration not working in secure mode

Found the issue and raised it and added a patch too : https://issues.cloudera.org/browse/HUE-3989

Announcements