Reply
Contributor
Posts: 37
Registered: ‎05-21-2018

My Hbase Thrift Server is not Running.

While starting the Hbase thrift sever via CM Mangaer an geeting bellow error:

 

4:43:00.537 PMWARNMetricsConfig
Cannot locate configuration: tried hadoop-metrics2-hbase.properties,hadoop-metrics2.properties
4:43:00.859 PMINFOMetricsSystemImpl
Scheduled snapshot period at 10 second(s).
4:43:00.860 PMINFOMetricsSystemImpl
HBase metrics system started
Posts: 953
Topics: 1
Kudos: 226
Solutions: 121
Registered: ‎04-22-2014

Re: My Hbase Thrift Server is not Running.

@prabhat10,

 

The log lines provided are not errors and probably don't have anything to do with the server not starting.

 

Some things to review to identify why the server is not starting:

 

(1)

The stdout.log and stderr.log files for the Hbase Thrift server

 

In Cloudera Manager, go to Hbase --> Instances --> Hbase Thrift Server

 

When in the Hbase Thrift Server page, click the "Log Files" drop-down and choose stout.log and stderr.log.  Generally, the last lines of the stderr.log file will indicate if the supervisor was able to start up the process or not.

 

(2)

 

If there are no errors at the bottom of the stderr.log, then it is likely the Hbase Thrift Server started up but then failed for some reason.  In this case, you want to have a look at the Hbase Thrift Server logs.

 

You can also view "Role Log" in the "Log Files" drop down in Cloudera Manager to view the role log.  It may be easier to read via the command line, though.  If you can, ssh to the host where the Hbase Thrift Server should be running and navigate to /var/log/hbase.

 

You will see your HBASETHRIFTSERVER log file(s) there and you can review the logs for review.

 

(3)

 

What is the real problem you see?  What observations tell you that the server is having a problem?

 

 

Contributor
Posts: 37
Registered: ‎05-21-2018

Re: My Hbase Thrift Server is not Running.

[ Edited ]

Thanks, thrift server is started.

 

i want to access Hbase tables using Hue. But when it try to acess it shows API error:

 

initially it was showing api timeout error:.

then i edited hue.ini file using CM under configuration tab by clicking on advanced property.

and added following path where my hbase-site.xml is located

 

hbase_conf_dir= /etc/hbase/conf

 

hbase.regionserver.thrift.http == enabled
hbase.thrift.support.proxyuser = enabled

after saving this its showing api error. 

 

What to Do 

 

Kindly suggest

Posts: 953
Topics: 1
Kudos: 226
Solutions: 121
Registered: ‎04-22-2014

Re: My Hbase Thrift Server is not Running.

@prabhat10,

 

Thank you for clarifying.

 

In recent CDH versions, there should be no need to edit the "hbase_conf_dir" value as Cloudera Manager configures that on its own.

 

I would recommend reverting any changes you made to try to troubleshoot the issue and then recreate it.

Explain exactly what you are clicking on in Hue and what happens so we have some context for helping.

Next, look at the /var/log/hue/runcpserver.log file to see what messages or errors occur when Hue is attempting to connect to the thrift server.

 

If you are unsure what to do or what the messages show you, share with us your runcpserver.log output that shows time during your attempt to view tables in Hue

Contributor
Posts: 37
Registered: ‎05-21-2018

Re: My Hbase Thrift Server is not Running.

Thanks @bgooley for your response.

 

Here is the log file.

 

[16/Jul/2018 20:08:47 -0700] access INFO 182.70.14.175 root - "POST /desktop/log_analytics HTTP/1.1" returned in 2ms[16/Jul/2018 20:08:47 -0700] access INFO 182.70.14.175 root - "POST /desktop/api2/get_config/ HTTP/1.1" returned in 267ms [16/Jul/2018 20:08:47 -0700] access INFO 182.70.14.175 root - "POST /notebook/api/create_notebook HTTP/1.1" returned in 8ms [16/Jul/2018 20:08:49 -0700] access INFO 182.70.14.175 root - "GET /jobbrowser/apps HTTP/1.1" returned in 2149ms [16/Jul/2018 20:08:51 -0700] connectionpool INFO Starting new HTTP connection (1): ac1.c.ascendant-baton-209807.internal:8088 [16/Jul/2018 20:08:51 -0700] navigator_api ERROR Navigator API is not configured. Traceback (most recent call last): File "/opt/cloudera/parcels/CDH-5.15.0-1.cdh5.15.0.p0.21/lib/hue/desktop/libs/metadata/src/metadata/navigator_api.py", line 60, in decorator raise MetadataApiException('Navigator API is not configured.') MetadataApiException: Navigator API is not configured. [16/Jul/2018 20:08:51 -0700] access INFO 182.70.14.175 root - "POST /metadata/api/navigator/list_tags HTTP/1.1" returned in 4ms [16/Jul/2018 20:08:53 -0700] connectionpool INFO Starting new HTTP connection (2): ac1.c.ascendant-baton-209807.internal:8088 [16/Jul/2018 20:08:53 -0700] access INFO 182.70.14.175 root - "GET /notebook/api/get_history HTTP/1.1" returned in 91ms [16/Jul/2018 20:08:54 -0700] access INFO 182.70.14.175 root - "GET /desktop/api2/doc/ HTTP/1.1" returned in 670ms [16/Jul/2018 20:08:59 -0700] access INFO 182.70.14.175 root - "GET /editor HTTP/1.1" returned in 3194ms [16/Jul/2018 20:09:01 -0700] resource WARNING SLOW: 9.81 - GET /cluster/apps Got response in 9809ms: {"apps":null} [16/Jul/2018 20:09:01 -0700] access INFO 182.70.14.175 root - "POST /jobbrowser/jobs/ HTTP/1.1" returned in 9831ms [16/Jul/2018 20:09:02 -0700] resource WARNING SLOW: 9.08 - GET /cluster/apps Got response in 9082ms: {"apps":null} [16/Jul/2018 20:09:02 -0700] access INFO 182.70.14.175 root - "POST /jobbrowser/jobs/ HTTP/1.1" returned in 9087ms [16/Jul/2018 20:09:08 -0700] access INFO 182.70.14.175 root - "GET /static/jobbrowser/css/jobbrowser-embeddable.8758b297189a.css HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:08 -0700] access INFO 182.70.14.175 root - "GET /static/oozie/js/dashboard-utils.507e03dba390.js HTTP/1.1" returned in 3ms [16/Jul/2018 20:09:08 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/css/basictable.b6811a116dc2.css HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:11 -0700] access INFO 182.70.14.175 root - "GET /static/notebook/css/notebook.b584e57a3b53.css HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:11 -0700] access INFO 182.70.14.175 root - "GET /static/dashboard/css/common_dashboard.8e99ca896494.css HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:11 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/css/bootstrap-editable.99dc2b3d2084.css HTTP/1.1" returned in 3ms [16/Jul/2018 20:09:11 -0700] access INFO 182.70.14.175 root - "GET /hbase/api/getClusters HTTP/1.1" returned in 11ms [16/Jul/2018 20:09:13 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/chosen/chosen.min.9ed7949517ef.css HTTP/1.1" returned in 2ms [16/Jul/2018 20:09:14 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/select2/select2.ab3d6393c695.css HTTP/1.1" returned in 2ms [16/Jul/2018 20:09:16 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/css/medium-editor.min.e708e7c9febc.css HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:16 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/css/bootstrap-medium-editor.307d202ce21d.css HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:21 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/css/jquery.mCustomScrollbar.min.f59e3f4c0087.css HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:21 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/js/clipboard.min.3e5e0fa949e0.js HTTP/1.1" returned in 3ms [16/Jul/2018 20:09:21 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/js/dagre-d3-min.bfeabe61df62.js HTTP/1.1" returned in 12ms [16/Jul/2018 20:09:21 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/js/autocomplete/sqlStatementsParser.a4d37b2d5a76.js HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:21 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/js/jquery.hdfstree.c06a50211b92.js HTTP/1.1" returned in 2ms [16/Jul/2018 20:09:22 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/js/markdown.min.e96d24cf1ba1.js HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:22 -0700] access INFO 182.70.14.175 root - "GET /static/jobbrowser/js/impala_dagre.b82bf41f605c.js HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:22 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/js/jquery/plugins/jquery.hotkeys.0297fddaacc8.js HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:23 -0700] access INFO 10.142.0.3 -anon- - "HEAD /desktop/debug/is_alive HTTP/1.1" returned in 6ms [16/Jul/2018 20:09:29 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/js/jquery/plugins/jquery.mousewheel.min.d5843dbdc71f.js HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:35 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/js/jquery.mCustomScrollbar.concat.min.42a368e95b4a.js HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:42 -0700] resource INFO SLOW: 3.74 - GET /cluster/apps Got response in 3735ms: {"apps":null} [16/Jul/2018 20:09:42 -0700] access INFO 182.70.14.175 root - "POST /jobbrowser/jobs/ HTTP/1.1" returned in 3740ms [16/Jul/2018 20:09:44 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/chosen/chosen.jquery.min.c54ebcf2f584.js HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:45 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/select2/select2.min.1f7c499bbb35.js HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:54 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/js/medium-editor.min.71abfe17ad4b.js HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:55 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/js/ko.common-dashboard.95a30593ad2d.js HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:55 -0700] access INFO 182.70.14.175 root - "POST /notebook/api/create_notebook HTTP/1.1" returned in 1ms [16/Jul/2018 20:09:56 -0700] access INFO 182.70.14.175 root - "GET /desktop/api2/user_preferences/default_app HTTP/1.1" returned in 3ms [16/Jul/2018 20:09:56 -0700] access INFO 182.70.14.175 root - "GET /desktop/workers/aceSqlLocationWorker.js HTTP/1.1" returned in 62ms [16/Jul/2018 20:09:56 -0700] access INFO 182.70.14.175 root - "GET /notebook/api/get_history HTTP/1.1" returned in 7ms [16/Jul/2018 20:09:56 -0700] access INFO 182.70.14.175 root - "GET /desktop/workers/aceSqlSyntaxWorker.js HTTP/1.1" returned in 92ms [16/Jul/2018 20:09:56 -0700] access INFO 182.70.14.175 root - "POST /jobbrowser/jobs/ HTTP/1.1" returned in 30ms [16/Jul/2018 20:09:56 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/js/ace/theme-hue.js HTTP/1.1" returned in 15ms [16/Jul/2018 20:09:56 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/js/ace/snippets/hive.js HTTP/1.1" returned in 83ms [16/Jul/2018 20:09:56 -0700] access INFO 182.70.14.175 root - "GET /desktop/api2/docs/ HTTP/1.1" returned in 17ms [16/Jul/2018 20:09:57 -0700] access INFO 182.70.14.175 root - "POST /notebook/api/create_session HTTP/1.1" returned in 201ms [16/Jul/2018 20:09:57 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/js/autocomplete/sqlSyntaxParser.58bf589741e7.js HTTP/1.1" returned in 12ms [16/Jul/2018 20:09:57 -0700] hive_server2_lib INFO beeswax: use_sasl=True, mechanism=PLAIN, kerberos_principal_short_name=None, impersonation_enabled=True, auth_username=hue [16/Jul/2018 20:09:58 -0700] hive_server2_lib INFO Retrying with a new session because for root of TGetSchemasResp(status=TStatus(errorCode=0, errorMessage='Invalid SessionHandle: SessionHandle [b3da4dac-48f5-448e-9baa-a6771f6229b2]', sqlState=None, infoMessages=['*org.apache.hive.service.cli.HiveSQLException:Invalid SessionHandle: SessionHandle [b3da4dac-48f5-448e-9baa-a6771f6229b2]:12:11', 'org.apache.hive.service.cli.session.SessionManager:getSession:SessionManager.java:432', 'org.apache.hive.service.cli.CLIService:getSchemas:CLIService.java:320', 'org.apache.hive.service.cli.thrift.ThriftCLIService:GetSchemas:ThriftCLIService.java:546', 'org.apache.hive.service.cli.thrift.TCLIService$Processor$GetSchemas:getResult:TCLIService.java:1373', 'org.apache.hive.service.cli.thrift.TCLIService$Processor$GetSchemas:getResult:TCLIService.java:1358', 'org.apache.thrift.ProcessFunction:process:ProcessFunction.java:39', 'org.apache.thrift.TBaseProcessor:process:TBaseProcessor.java:39', 'org.apache.hive.service.auth.TSetIpAddressProcessor:process:TSetIpAddressProcessor.java:56', 'org.apache.thrift.server.TThreadPoolServer$WorkerProcess:run:TThreadPoolServer.java:286', 'java.util.concurrent.ThreadPoolExecutor:runWorker:ThreadPoolExecutor.java:1149', 'java.util.concurrent.ThreadPoolExecutor$Worker:run:ThreadPoolExecutor.java:624', 'java.lang.Thread:run:Thread.java:748'], statusCode=3), operationHandle=None) [16/Jul/2018 20:09:58 -0700] hive_server2_lib INFO Opening beeswax thrift session for user root [16/Jul/2018 20:10:18 -0700] thrift_util WARNING SLOW: 8.33 - Thrift call: hbased.Hbase.Client.getTableNames(args=(), kwargs={'doas': u'root'}) returned in 8331ms: ['beta1', 'beta99', 'emp', 'qwe1', 'sample'] [16/Jul/2018 20:10:19 -0700] access INFO 182.70.14.175 root - "POST /jobbrowser/jobs/ HTTP/1.1" returned in 20ms [16/Jul/2018 20:10:21 -0700] thrift_util INFO SLOW: 2.87 - Thrift call: hbased.Hbase.Client.isTableEnabled(args=('beta1',), kwargs={'doas': u'root'}) returned in 2870ms: True [16/Jul/2018 20:10:22 -0700] thrift_util INFO SLOW: 1.65 - Thrift call: hbased.Hbase.Client.isTableEnabled(args=('beta99',), kwargs={'doas': u'root'}) returned in 1646ms: True [16/Jul/2018 20:10:23 -0700] access INFO 10.142.0.3 -anon- - "HEAD /desktop/debug/is_alive HTTP/1.1" returned in 4ms [16/Jul/2018 20:10:25 -0700] thrift_util INFO SLOW: 2.36 - Thrift call: hbased.Hbase.Client.isTableEnabled(args=('emp',), kwargs={'doas': u'root'}) returned in 2356ms: True [16/Jul/2018 20:10:26 -0700] thrift_util WARNING SLOW: 27.75 - Thrift call: <class 'TCLIService.TCLIService.Client'>.OpenSession(args=(TOpenSessionReq(username='hue', password=None, client_protocol=6, configuration={'hive.server2.proxy.user': u'root'}),), kwargs={}) returned in 27748ms: TOpenSessionResp(status=TStatus(errorCode=None, errorMessage=None, sqlState=None, infoMessages=None, statusCode=0), sessionHandle=TSessionHandle(sessionId=THandleIdentifier(secret=fc4174a460dbffc2:a70e91db1c9f7c84, guid=3d46ed646f3340b1:5dbe2e16127091b6)), configuration={}, serverProtocolVersion=6) [16/Jul/2018 20:10:26 -0700] hive_server2_lib INFO Session '\xb1@3od\xedF=\xb6\x91p\x12\x16.\xbe]' opened [16/Jul/2018 20:10:28 -0700] access INFO 182.70.14.175 root - "POST /notebook/api/autocomplete/ HTTP/1.1" returned in 30652ms [16/Jul/2018 20:10:28 -0700] thrift_util INFO SLOW: 3.96 - Thrift call: hbased.Hbase.Client.isTableEnabled(args=('qwe1',), kwargs={'doas': u'root'}) returned in 3960ms: True [16/Jul/2018 20:10:30 -0700] thrift_util INFO SLOW: 1.58 - Thrift call: hbased.Hbase.Client.isTableEnabled(args=('sample',), kwargs={'doas': u'root'}) returned in 1575ms: True [16/Jul/2018 20:10:30 -0700] access INFO 182.70.14.175 root - "GET /hbase/api/getTableList/HBase HTTP/1.1" returned in 24336ms [16/Jul/2018 20:10:31 -0700] access INFO 182.70.14.175 root - "POST /notebook/api/autocomplete/default HTTP/1.1" returned in 344ms.hive.service.cli.HiveSQLException:Invalid SessionHandle: SessionHandle [b3da4dac-48f5-448e-9baa-a6771f6229b2]:12:11', 'org.apache.hive.serv[16/Jul/2018 20:10:37 -0700] access INFO 182.70.14.175 root - "GET /hbase/ HTTP/1.1" returned in 582ms[16/Jul/2018 20:10:41 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/js/datatables-paging-0.1.c7700cc4f121.js HTTP/1.1" returned in 1ms[16/Jul/2018 20:10:50 -0700] access INFO 182.70.14.175 root - "POST /jobbrowser/jobs/ HTTP/1.1" returned in 566ms[16/Jul/2018 20:11:03 -0700] access INFO 182.70.14.175 root - "GET /static/hbase/art/icon_hbase_48.3c45e75ac978.png HTTP/1.1" returned in 8ms[16/Jul/2018 20:11:03 -0700] access INFO 182.70.14.175 root - "GET /static/hbase/css/hbase.1eea2f8a2fc0.css HTTP/1.1" returned in 8ms[16/Jul/2018 20:11:03 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/js/hue.routie.d8e886e81f0e.js HTTP/1.1" returned in 11ms[16/Jul/2018 20:11:05 -0700] access INFO 182.70.14.175 root - "GET /static/desktop/ext/js/mustache.a9f934e40328.js HTTP/1.1" returned in 1ms[16/Jul/2018 20:11:06 -0700] access INFO 182.70.14.175 root - "POST /hbase/api/getClusters HTTP/1.1" returned in 10ms[16/Jul/2018 20:11:08 -0700] access INFO 182.70.14.175 root - "POST /hbase/api/getColumnDescriptors/HBase/beta99 HTTP/1.1" returned in 892ms[16/Jul/2018 20:11:15 -0700] thrift_util WARNING SLOW: 8.33 - Thrift call: hbased.Hbase.Client.scannerOpenWithScan(args=(u'beta99', TScan(stopRow=None, filterString='(ColumnPaginationFilter(500,0) AND PageFilter(500))', timestamp=None, batchSize=None, startRow='', caching=None, columns=[]), None), kwargs={'doas': u'root'}) returned in 8331ms: 0[16/Jul/2018 20:11:23 -0700] thrift_util WARNING SLOW: 7.69 - Thrift call: hbased.Hbase.Client.scannerGetList(args=(0, 10), kwargs={'doas': u'root'}) returned in 7687ms: [TRowResult(columns={'info:patient_name': TCell(timestamp=1531376997284, value='santosh10'), 'info:registration_id': TCell(timestamp=1531376960851, value='10009')}, row='10')][16/Jul/2018 20:11:23 -0700] access INFO 182.70.14.175 root - "POST /hbase/api/getRowQuerySet/HBase/beta99/[]/[{"row_key":"null","scan_length":10,"columns":[],"prefix":"false","filter":null,"editing":true}] HTTP/1.1" returned in 16037ms[16/Jul/2018 20:11:23 -0700] access INFO 10.142.0.3 -anon- - "HEAD /desktop/debug/is_alive HTTP/1.1" returned in 2ms[16/Jul/2018 20:11:25 -0700] resource INFO SLOW: 1.03 - GET /cluster/apps Got response in 1034ms: {"apps":null}[16/Jul/2018 20:11:25 -0700] access INFO 182.70.14.175 root - "POST /jobbrowser/jobs/ HTTP/1.1" returned in 1041ms[16/Jul/2018 20:12:01 -0700] resource INFO SLOW: 1.92 - GET /cluster/apps Got response in 1923ms: {"apps":null}[16/Jul/2018 20:12:01 -0700] access INFO 182.70.14.175 root - "POST /jobbrowser/jobs/ HTTP/1.1" returned in 1927ms[16/Jul/2018 20:12:23 -0700] access INFO 10.142.0.3 -anon- - "HEAD /desktop/debug/is_alive HTTP/1.1" returned in 2ms[16/Jul/2018 20:12:36 -0700] access INFO 182.70.14.175 root - "POST /jobbrowser/jobs/ HTTP/1.1" returned in 19ms[16/Jul/2018 20:13:09 -0700] resource INFO SLOW: 1.81 - GET /cluster/apps Got response in 1805ms: {"apps":null}[16/Jul/2018 20:13:09 -0700] access INFO 182.70.14.175 root - "POST /jobbrowser/jobs/ HTTP/1.1" returned in 1809ms[16/Jul/2018 20:13:24 -0700] access INFO 10.142.0.3 -anon- - "HEAD /desktop/debug/is_alive HTTP/1.1" returned in 19ms[root@ac2 acipoc01]#

Posts: 953
Topics: 1
Kudos: 226
Solutions: 121
Registered: ‎04-22-2014

Re: My Hbase Thrift Server is not Running.

@prabhat10,

 

The logs you pasted in came in one line; I was able to add some hard returns in to make it easier to read.  We can see that it appears that HBase Thrift calls are succeeding but slowly:

 

[16/Jul/2018 20:10:18 -0700] thrift_util WARNING SLOW: 8.33 - Thrift call: hbased.Hbase.Client.getTableNames(args=(), kwargs={'doas': u'root'}) returned in 8331ms:
['beta1', 'beta99', 'emp', 'qwe1', 'sample']

[16/Jul/2018 20:10:21 -0700] thrift_util INFO SLOW: 2.87 - Thrift call: hbased.Hbase.Client.isTableEnabled(args=('beta1',), kwargs={'doas': u'root'}) returned in 2870ms: True
[16/Jul/2018 20:10:22 -0700] thrift_util INFO SLOW: 1.65 - Thrift call: hbased.Hbase.Client.isTableEnabled(args=('beta99',), kwargs={'doas': u'root'}) returned in 1646ms: True

[16/Jul/2018 20:10:25 -0700] thrift_util INFO SLOW: 2.36 - Thrift call: hbased.Hbase.Client.isTableEnabled(args=('emp',), kwargs={'doas': u'root'}) returned in 2356ms: True

[16/Jul/2018 20:10:28 -0700] thrift_util INFO SLOW: 3.96 - Thrift call: hbased.Hbase.Client.isTableEnabled(args=('qwe1',), kwargs={'doas': u'root'}) returned in 3960ms: True
[16/Jul/2018 20:10:30 -0700] thrift_util INFO SLOW: 1.58 - Thrift call: hbased.Hbase.Client.isTableEnabled(args=('sample',), kwargs={'doas': u'root'}) returned in 1575ms: True

[16/Jul/2018 20:11:15 -0700] thrift_util WARNING SLOW: 8.33 - Thrift call: hbased.Hbase.Client.scannerOpenWithScan(args=(u'beta99', TScan(stopRow=None, filterString='(ColumnPaginationFilter(500,0) AND PageFilter(500))', timestamp=None, batchSize=None, startRow='', caching=None, columns=
[]), None), kwargs={'doas': u'root'}) returned in 8331ms: 0
[16/Jul/2018 20:11:23 -0700] thrift_util WARNING SLOW: 7.69 - Thrift call: hbased.Hbase.Client.scannerGetList(args=(0, 10), kwargs={'doas': u'root'}) returned in 7687ms:
[TRowResult(columns={'info:patient_name': TCell(timestamp=1531376997284, value='santosh10'), 'info:registration_id': TCell(timestamp=1531376960851, value='10009')}, row='10')]
[16/Jul/2018 20:11:23 -0700] access INFO 182.70.14.175 root - "POST /hbase/api/getRowQuerySet/HBase/beta99/
[]/
[{"row_key":"null","scan_length":10,"columns":
[],"prefix":"false","filter":null,"editing":true}] HTTP/1.1" returned in 16037ms

 

This indicates that the HBase Thrift Server is receiving the requests from Hue and is returning a result.

 

I noted in your log that it appears Hive requests are slow to return as well:

 

[16/Jul/2018 20:09:58 -0700] hive_server2_lib INFO Opening beeswax thrift session for user root

[16/Jul/2018 20:10:26 -0700] thrift_util WARNING SLOW: 27.75 - Thrift call: <class 'TCLIService.TCLIService.Client'>.OpenSession(args=(TOpenSessionReq(username='hue', password=None, client_protocol=6, configuration={'hive.server2.proxy.user': u'root'}),), kwargs={}) returned in 27748ms: TOpenSessionResp(status=TStatus(errorCode=None, errorMessage=None, sqlState=None, infoMessages=None, statusCode=0), sessionHandle=TSessionHandle(sessionId=THandleIdentifier(secret=fc4174a460dbffc2:a70e91db1c9f7c84, guid=3d46ed646f3340b1:5dbe2e16127091b6)), configuration={}, serverProtocolVersion=6)
[16/Jul/2018 20:10:26 -0700] hive_server2_lib INFO Session '\xb1@3od\xedF=\xb6\x91p\x12\x16.\xbe]' opened

 

This may indicate that one or more of your services is not able to perform as quickly as we may expect.  I would recommend looking more closely at the HBase Thrift Server itself to review its logs and see if there are any clues regarding what is taking longer than one would expect.  From what I see in the Hue log you provided, there is no indication that the HBase queries are failing at the Hue --> HBase Thrift connection side.

Highlighted
Contributor
Posts: 37
Registered: ‎05-21-2018

Re: My Hbase Thrift Server is not Running.

Thanks @bgooley

 

Its running now. I have installed the hbase again and itts working fine now.

 

 

Thanks for support.

Announcements