Reply
New Contributor
Posts: 1
Registered: ‎10-27-2014

Using spark-kafka-writer repository

Cloudera has an open source project called spark-kafka-writer (https://libraries.io/github/cloudera/spark-kafka-writer), which abstracts the complexity of writing to Kakfa on each RDD partition.

 

However, when attempting to access the Maven Repos (https://repository.cloudera.com/artifactory/cloudera-repos) we receive the following error upon connection: "Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty".

 

 

Does anyone know from where to get a maven repo for this project.

Posts: 1,894
Kudos: 433
Solutions: 303
Registered: ‎07-31-2013

Re: Using spark-kafka-writer repository

Where do you observe this error, and does it occur for all repository dependencies or just this one?

Do you override your local JVM TrustStore with something custom?

Effectively the error is coming out of no trust of the provided certificate by repository.cloudera.com, which is a proper signed certificate and should be trusted by the JVM's default TrustStore.