Reply
Posts: 384
Kudos: 7
Solutions: 5
Registered: ‎08-14-2013

Re: Cannot access to Oozie Web UI with Error message below

This worked for me with Oozie HA with haproxy running OpenJDK 1.8.   I did have to make sure the three jars were unlinked on both oozie servers in the /opt/cloudera/parcels/CDH/lib/oozie/embedded-oozie-server/dependency/ directory.   Could it be possible that you may have these jars elsewhere in the classpath for oozie, maybe in the /var/lib/oozie directory?

 

unlink ./jetty-runner-9.3.20.v20170531.jar
unlink ./javax.servlet.jsp-api-2.3.1.jar
unlink ./javax.servlet.jsp-2.3.2.jar

 

Oozie_Web_Console_and_Instances_-_Oozie_-_Cloudera_Manager_and_1__cloudera_host-10-17-100-72____ssh__and_Oozie_Web_Console.png



Robert Justice, Technical Resolution Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:

Terms of Service

New Contributor
Posts: 5
Registered: ‎01-31-2019

Re: Cannot access to Oozie Web UI with Error message below

[ Edited ]

Yes, I found the jar in other places, I remove the link, now the oozie web ui work fine! Thank you!

Now I try to fix the oozie ha problem.