Reply
Explorer
Posts: 40
Registered: ‎01-13-2017
Accepted Solution

Hive hive.prewarm.enabled property

Hello.

 

Anyone knows in what file i may update hive.prewarm.enabled property ?

I've checked hive-site.xml and that property does not exist.

 

Thanks

Posts: 519
Topics: 14
Kudos: 92
Solutions: 45
Registered: ‎09-02-2016

Re: Hive hive.prewarm.enabled property

@MasterOfPuppets

 

When you configure Hive, hive-site.xml will be updated with default property. So you can customize hive-site.xml by adding addional property.

 

Instead of directly updating hive-site.xml, i would recommend you to update via CM. You can follow the below steps

CM -> Hive -> Configuration -> Advanced Category -> search for snippet -> It will show you option to add additional property.

 

Press + button, Name = "hive.prewarm.enabled" and value to be "true" to enable it
Press ? button, to know more about each property

 

Thanks

Kumar

Explorer
Posts: 40
Registered: ‎01-13-2017

Re: Hive hive.prewarm.enabled property

Thanks for the feedback..This is exactly what i was looking for.

Cloudera Employee
Posts: 18
Registered: ‎01-12-2017

Re: Hive hive.prewarm.enabled property

You can try setting it in Hive service's configuration page. Search for 'Hive Service Advanced Configuration Snippet (Safety Valve) for hive-site.xml' and add an entry for this. Then you might probably want to restart Hive service.

Highlighted
Explorer
Posts: 40
Registered: ‎01-13-2017

Re: Hive hive.prewarm.enabled property

I've set-up hive.prewarm.enabled=true   and it did not improve the slow latency to start and initialize executors.

It still takes about 15seconds to initialize things. Any idea ?

Announcements