Reply
New Contributor
Posts: 5
Registered: ‎09-14-2016

ozzie shell script not executing...error Main class [org.apache.oozie.action.hadoop.ShellMain], exit

job.properties

 

nameNode=hdfs://ns613.mycyberhosting.com:54310
jobTracker=ns613.mycyberhosting.com:8032
queueName=default
user.name=root
oozie.libpath=${nameNode}/user/root/share/lib/lib_20160905172157
oozie.use.system.libpath=true
seeds_shRoot=seeds_sh
oozie.wf.application.path=${nameNode}/user/${user.name}/${seeds_shRoot}/apps/shell

 

workflow.xml

 

<?xml version="1.0" encoding="UTF-8"?>
<workflow-app xmlns="uri:oozie:workflow:0.4" name="seeds-shell-wf">
<start to="seed-shell"/>
<action name="seed-shell">
<shell xmlns="uri:oozie:shell-action:0.1">
<job-tracker>${jobTracker}</job-tracker>
<name-node>${nameNode}</name-node>
<exec>job.sh</exec>
<env-var>HADOOP_USER_NAME=root</env-var>
<file>/user/root/seeds_sh/job.sh#job.sh</file>
</shell>
<ok to="end"/>
<error to="kill"/>
</action>
<kill name="kill">
<message>Action failed, error message[${wf:errorMessage(wf:lastErrorNode())}]</message>
</kill>
<end name="end"/>
</workflow-app>

 

script- job.sh

/home/c1/apache-nutch-2.3.1/runtime/deploy/bin/crawl /user/root/seeds_sh/input-data/seeds_test 2 http://ns613.mycyberhosting.com:8983/solr/ddcds 1

 

plz help to execute this with oozie

thanks & regards

himanshu kukreja

New Contributor
Posts: 5
Registered: ‎09-14-2016

Re: ozzie shell script not executing...error Main class [org.apache.oozie.action.hadoop.ShellMain],

any suggestions or help? 

New Contributor
Posts: 5
Registered: ‎09-14-2016

Re: ozzie shell script not executing...error Main class [org.apache.oozie.action.hadoop.ShellMain],

any help will be appreciated? thanks

Cloudera Employee
Posts: 24
Registered: ‎06-17-2016

Re: ozzie shell script not executing...error Main class [org.apache.oozie.action.hadoop.ShellMain],

Probably there is something going wrong inside the shell script. Whithout ant logs or concrete exception it's very hard to say anything.

New Contributor
Posts: 5
Registered: ‎09-14-2016

Re: ozzie shell script not executing...error Main class [org.apache.oozie.action.hadoop.ShellMain],

[ Edited ]

ok thank you!! I got the error resolved. i was missing certain libraries while passing the script. Now i am stuck with other issue like job gets stuck in running state it might be due to scheduler. Which scheduler is better to use in a 3 node  hadoop 2.x cluster? Fair or capacity? can any one help me out with configuration of these 2 and how it works? How queues are being used?

Any help would be appreciated... Thanks