Reply
Cloudera Employee
Posts: 69
Registered: ‎10-14-2014

Re: Altus Director 6.2 Azure deployment fails when using Azure Postgresql

Also, to clarify: we're talking about Azure Database for PostgreSQL (https://azure.microsoft.com/en-us/services/postgresql/) and Azure Database for MySQL (https://azure.microsoft.com/en-us/services/mysql/), correct?
Expert Contributor
Posts: 77
Registered: ‎10-02-2017

Re: Altus Director 6.2 Azure deployment fails when using Azure Postgresql

That is correct.

Cloudera Employee
Posts: 69
Registered: ‎10-14-2014

Re: Altus Director 6.2 Azure deployment fails when using Azure Postgresql

One more clarification: in the config file, are you using explicit databases keyword (https://github.com/cloudera/director-scripts/blob/master/configs/azure.reference.conf#L710), or are you using databaseTemplates (https://github.com/cloudera/director-scripts/blob/master/configs/azure.reference.conf#L746)?
Highlighted
Expert Contributor
Posts: 77
Registered: ‎10-02-2017

Re: Altus Director 6.2 Azure deployment fails when using Azure Postgresql

We are using option for existing external databases which we launch and prepare prior to bootstrapping the cluster.  I believe in the cluster config spec it's referred to as:

 

"(Option 2) Optional configuration for existing external databases"

 

So, basically we launch an Azure Postgresql database and run DDL to setup CDH service databases, users, roles and refer to this DB in the cluster definition spec passed to Altus Director.  We do the same for AWS deployments, using RDS for Postgresql.   As I mentioned earlier in the thread, this was working fine in Azure with Altus Director 2.8.  

Expert Contributor
Posts: 77
Registered: ‎10-02-2017

Re: Altus Director 6.2 Azure deployment fails when using Azure Postgresql

Any luck with your testing?  Can we expect a patch soon?

 

 

Thanks

Cloudera Employee
Posts: 69
Registered: ‎10-14-2014

Re: Altus Director 6.2 Azure deployment fails when using Azure Postgresql

Hi! Sorry for the delay. Director 6.2.1 was released today with this (hopefully) patched. Do you mind testing and letting me know? Thank you!
Expert Contributor
Posts: 77
Registered: ‎10-02-2017

Re: Altus Director 6.2 Azure deployment fails when using Azure Postgresql

I will absolutely test and let you know.  I should have results to report within the next few days.

Cloudera Employee
Posts: 69
Registered: ‎10-14-2014

Re: Altus Director 6.2 Azure deployment fails when using Azure Postgresql

Hi dturner. Just wondering if you had had a chance to test this -- let me know!