New Contributor
Posts: 2
Registered: ‎07-14-2017
Accepted Solution

Configuration step to use GPU fails under proxy environment

[ Edited ]



I am configuring CDSW to use NVIDIA GPU in the environment where the Proxy server exists based on the procedures here:


However, I got the following error message when I tried to pull the docker image:


$sudo nvidia-docker run --rm nvidia/cuda:9.2-devel-ubuntu16.04 nvidia-smi
nvidia-docker | 2018/10/08 13:14:19 Error: Error response from daemon: Get net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)


I guess the root cause may be related to improper DNS or Proxy setting and I reviewed them many times, but I can still not solve the problem.


One weird thing I found is that 'sudo cdsw status -v' resulted in the following error when I configured 'HTTP Proxy' from 'Cloudera Manager > CDSW > Configuration > Cloudera Data Science Workbench (Service-Wide)':


{metric: http_port_check, status: FAILURE, report_to_cm: True, timestampMs: 1538973062774, message: HTTP port check timed out after 60 seconds.}


The error was cleared when I deleted the HTTP Proxy configuration, but I could not do the 'docker run' command.


I am using **bleep**.io for the wildcard DNS subdomain requirement.


Any suggestion would be appreciated.


Cloudera Employee
Posts: 43
Registered: ‎07-09-2015

Re: Configuration step to use GPU fails under proxy environment



We are tracking an issue where the docker daemon is not picking up the proxy configuration. The easiest workaround is to download the 'nvidia/cuda:9.2-devel-ubuntu16.04' image to your local computer and move the image with the docker save; scp; docker load commands to the CDSW host. After doing this the 'nvidia-docker run' should work.